Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Android error #4

Closed
yfuks opened this issue Dec 9, 2015 · 6 comments
Closed

Android error #4

yfuks opened this issue Dec 9, 2015 · 6 comments

Comments

@yfuks
Copy link

@yfuks yfuks commented Dec 9, 2015

Hello, i just try to use this module on an Android device and i get the folowing error :

error

there is my code (realy simple) :

'use strict';

var React = require('react-native');
var ParsedText = require('react-native-parsed-text');
var {
  Component,
  Text,
  View
} = React;

class Home extends Component {
  constructor (props) {
    super(props);
  }
  render() {
    return (
      <View style={{flex: 1}}>
        <Text style={{marginVertical: 20, marginHorizontal: 10}}>Welcome</Text>
        <ParsedText style={{color: 'black', fontSize: 15}} parse={  [ {type: 'url', style: {color: '#456'}, onPress: () => {}} ] } >hello</ParsedText>
      </View>
    );
  }
}

module.exports = Home;

My api version : API 18

So is this module supposed to work on Android or did i miss something ?

@jrichardlai
Copy link
Contributor

@jrichardlai jrichardlai commented Dec 9, 2015

I thought this should work out of the box for Android, definitely planning to support Android.
Thanks for letting me now.

@yfuks
Copy link
Author

@yfuks yfuks commented Dec 9, 2015

Nice !
Really look for it !

@yfuks
Copy link
Author

@yfuks yfuks commented Dec 10, 2015

Any idea on the timeline for this ?

@jrichardlai
Copy link
Contributor

@jrichardlai jrichardlai commented Dec 10, 2015

Sorry pretty busy at the moment, which version of react native are you using ?

@yfuks
Copy link
Author

@yfuks yfuks commented Dec 10, 2015

0.15.0 actually

@jrichardlai
Copy link
Contributor

@jrichardlai jrichardlai commented Dec 13, 2015

Okay fixed it should be good for 0.0.8 version

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.