New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

home page search not working. #124

Closed
aslamrs opened this Issue Jun 21, 2016 · 15 comments

Comments

Projects
None yet
@aslamrs

aslamrs commented Jun 21, 2016

image

@shivamriky

This comment has been minimized.

Collaborator

shivamriky commented Jul 6, 2016

Hi! Can I ask what are you trying to search?
Is it one of your location?

@aslamrs

This comment has been minimized.

aslamrs commented Jul 7, 2016

Yes

@monstermage

This comment has been minimized.

monstermage commented Jul 27, 2016

Did you connect google API and make a delivery area that consists of the address you are attempting to locate?

@akberkhan1990

This comment has been minimized.

akberkhan1990 commented Nov 14, 2016

i am also facing the same issue, unable to resolve

@janmohds

This comment has been minimized.

janmohds commented Nov 28, 2016

It works if you configure your Google API and set delivery areas.

https://developers.google.com/maps/documentation/javascript/

@sampoyigi sampoyigi added the question label Nov 29, 2016

@novastream

This comment has been minimized.

novastream commented Jan 11, 2017

Here is the things I did to get the search working...

admin/controllers/Locations.php
Change:
$this->template->setScriptTag('https://maps.googleapis.com/maps/api/js?v=3' . $data['map_key'] .'&sensor=false&region=GB&libraries=geometry', 'google-maps-js', '104330');
To (removing sensor and changing region to your region):
$this->template->setScriptTag('https://maps.googleapis.com/maps/api/js?v=3' . $data['map_key'] .'&region=SE&libraries=geometry', 'google-maps-js', '104330');

system/tastyigniter/libraries/Location.php
Change:
$url = 'https://maps.googleapis.com/maps/api/geocode/json?address=' . urlencode($temp_query); //encode $postcode string and construct the url query $ch = curl_init(); curl_setopt($ch, CURLOPT_URL, $url); curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1); curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, 1); curl_setopt($ch, CURLOPT_USERAGENT, $this->CI->agent->agent_string()); $geocode_data = curl_exec($ch); curl_close($ch);

To (you can add a timeout as well):
$url = 'https://maps.googleapis.com/maps/api/geocode/json?address=' . urlencode($temp_query); //encode $postcode string and construct the url query $ch = curl_init(); curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false); curl_setopt($ch, CURLOPT_RETURNTRANSFER, true); curl_setopt($ch, CURLOPT_URL, $url); $geocode_data = curl_exec($ch); curl_close($ch);

Settings

  1. Go to System < Settings and set your Google Javascript API key
  2. Go to Restaurant < Locations < Edit your Restaurants
  3. Set "Automatically fetch lat/lng" to "No" and set your lat/lang manually
  4. Go to the Delivery tab, create atleast 1 area
@mosesmos1

This comment has been minimized.

mosesmos1 commented Jan 28, 2017

I have added Google API code and delivery area as well but still i am facing this issue : We couldn't locate the entered address/postcode, please enter a valid address/postcode.

@novastream

This comment has been minimized.

novastream commented Jan 28, 2017

Did you do The steps I provided above or did you just add the Google api code and created an area?

@mosesmos1

This comment has been minimized.

mosesmos1 commented Jan 28, 2017

Yes I did the above steps as well. Still no luck.
Thanks for your response. Looking forward to hear from you with solution.
Thank you

@bhukkhar

This comment has been minimized.

bhukkhar commented Feb 20, 2017

Hello there please update your location and delivery areas to get this problem sorted.
Check your co-ordinates and then update your delivery areas . i guess this will solve your problem.

@shivamriky

This comment has been minimized.

Collaborator

shivamriky commented Mar 2, 2017

Is this issue resolved?

@atifmerghad

This comment has been minimized.

atifmerghad commented Sep 20, 2017

hello, when i press view menu or login or register ==> i get this error.
capture

@sampoyigi

This comment has been minimized.

Member

sampoyigi commented Oct 20, 2017

@atifmerghad Use issues to report bugs, please post your questions on the forums or better still search the forums for existing solutions.

@sampoyigi sampoyigi closed this Oct 20, 2017

@asifstar19

This comment has been minimized.

asifstar19 commented Oct 24, 2017

i am facing same wamp issue....

@letssmokegood

This comment has been minimized.

letssmokegood commented Oct 15, 2018

Hey guys support for this software isn't that great, I did come across this link which solved the issue for me. Hope it helps if not at least i'll be able to find it later
https://tastyigniter.slack.com/files/U906D6LTX/FD6F7PZGD/location.php

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment