Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Browse files

(#7506) Specify supported Ruby versions in

The README was not specific enough about the current state of our Ruby support.
This commit lays out our current status as discussed in issue #7506 and in
greater detail on the internal mailing list around April 8, 2011 under the
subject "Statler Ruby Versions Support."

Paired-With: Matt Robinson <>
  • Loading branch information...
commit 1a33bf86b74053f7978bddb6b1f715d04db9f2ba 1 parent d4c499d
nfagerlund authored
Showing with 6 additions and 2 deletions.
  1. +6 −2
@@ -5,7 +5,7 @@ Puppet, an automated administrative engine for your Linux and Unix systems, perf
administrative tasks (such as adding users, installing packages, and updating server
configurations) based on a centralized specification.
-Documentation (and detailed installation instructions) can be found online at the
+Documentation (and detailed installation instructions) can be found online at the
[Puppet Docs site](
@@ -13,7 +13,11 @@ Installation
Generally, you need the following things installed:
-* Ruby >= 1.8.1 (earlier releases might work but probably not)
+* A supported Ruby version. Ruby 1.8.5, 1.8.7, and 1.9.2 are fully supported
+ (with a handful of known issues under 1.9.2); Ruby 1.8.1 is supported on a
+ best-effort basis for agent use only. Other versions of Ruby are used at your
+ own risk, and Ruby 1.8.6, 1.9.0, and 1.9.1 are not recommended for
+ compatibility reasons.
* The Ruby OpenSSL library. For some reason, this often isn't included
in the main ruby distributions. You can test for it by running
Please sign in to comment.
Something went wrong with that request. Please try again.