Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ignore version of core gem #79

Merged
merged 1 commit into from Jan 4, 2014
Merged

ignore version of core gem #79

merged 1 commit into from Jan 4, 2014

Conversation

@tdtds
Copy link
Member

tdtds commented Jan 4, 2014

開発中はcoreのGemfileに「gem 'tdiary-contrib', path: '../contrib'」とか書きたくなるのだけど、contribがcore gemのバージョンチェックをしているせいでうまくbundleできません。いっそ無視しちゃってもいいんじゃないかと思うのだけど、どうでしょう? @machu

@machu

This comment has been minimized.

Copy link
Member

machu commented Jan 4, 2014

手元の環境では gem 'tdiary-contrib', :path => '../tdiary-contrib' と書いても動いている…と思ったら、ローカルに入れたgemのtdiary/versionを読んでいました。
厳密には tdiary/tdiary-core#375 対応の TDiary::Extension が入った 4.0.2.20131215 以降に依存していますが、「ContribはCoreのHEADのみサポート」の方針に則って無視しちゃっていいです。

machu added a commit that referenced this pull request Jan 4, 2014
ignore version of core gem
@machu machu merged commit a71d6a2 into master Jan 4, 2014
1 check passed
1 check passed
default The Travis CI build passed
Details
@machu machu deleted the ignore_core_version branch Jan 4, 2014
@machu

This comment has been minimized.

Copy link
Member

machu commented Jan 4, 2014

ちなみに、もともとTDiary::Versionに依存させていたのは、3ヶ月ごとのリリース時だけGemを作ることを想定していたからでした。SubversionやGitのタグがCoreとContribで同期しているのと同じ考えです。
今はContribが独立したバージョンを持つようになったので、TDiary::Versionに依存する必要はないです。

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.