This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

doc/gemspec updates

  • Loading branch information...
technomancy committed Jul 24, 2008
1 parent 0a509d7 commit 692397c63d32f1a0d2a15a77b62200804e60f224
Showing with 16 additions and 6 deletions.
  1. +5 −2 README.rdoc
  2. +3 −0 Rakefile
  3. +8 −4 conspire.gemspec
View
@@ -26,9 +26,12 @@ Conspiracy sessions operate around repositories rather than single
files like other collaborative editors. So launch +conspire+ with a
directory as its first argument to have it initialize a repository in
that directory. From there you should open up your editor and invoke
-conspire from there.
+conspire from there on the files with which you wish to collaborate.
-See lib/conspire/support to see which editors are supported.
+See lib/conspire/support to see which editors are supported. In Emacs,
+this involves visiting the file you want to edit and pressing M-x
+conspire-mode, though this is still very rough and should be done in
+its own instance.
Repository history is cleared in between conspiracy sessions.
View
@@ -7,6 +7,9 @@ require './lib/conspire.rb'
Hoe.new('conspire', Conspire::VERSION) do |p|
p.developer('Phil Hagelberg', 'technomancy@gmail.com')
+ p.summary = 'Conspire is a real-time collaborative editing platform using Git as a transport layer.'
+ p.url = 'http://conspire.rubyforge.org'
+
p.extra_deps << ['gitjour', '6.3.0']
p.extra_deps << 'clip'
end
View
@@ -11,26 +11,30 @@ Gem::Specification.new do |s|
s.extra_rdoc_files = ["History.txt", "Manifest.txt", "README.txt"]
s.files = ["COPYING", "History.txt", "Manifest.txt", "README.txt", "Rakefile", "bin/conspire", "lib/conspire.rb", "lib/conspire/conspirator.rb", "lib/conspire/gitjour_exts.rb", "lib/conspire/support/conspire.el", "test/test_conspire.rb"]
s.has_rdoc = true
+ s.homepage = %q{http://bus-scheme.rubyforge.org}
s.rdoc_options = ["--main", "README.txt"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{conspire}
s.rubygems_version = %q{1.2.0}
- s.summary = nil
+ s.summary = %q{Conspire is a real-time collaborative editing platform using Git as a transport layer.}
s.test_files = ["test/test_conspire.rb"]
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 2
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<chad-gitjour>, [">= 0"])
+ s.add_runtime_dependency(%q<gitjour>, ["= 6.3.0"])
+ s.add_runtime_dependency(%q<clip>, [">= 0"])
s.add_development_dependency(%q<hoe>, [">= 1.7.0"])
else
- s.add_dependency(%q<chad-gitjour>, [">= 0"])
+ s.add_dependency(%q<gitjour>, ["= 6.3.0"])
+ s.add_dependency(%q<clip>, [">= 0"])
s.add_dependency(%q<hoe>, [">= 1.7.0"])
end
else
- s.add_dependency(%q<chad-gitjour>, [">= 0"])
+ s.add_dependency(%q<gitjour>, ["= 6.3.0"])
+ s.add_dependency(%q<clip>, [">= 0"])
s.add_dependency(%q<hoe>, [">= 1.7.0"])
end
end

0 comments on commit 692397c

Please sign in to comment.