Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

(void-variable hippie-expand-try-functions-list) #151

Open
kencausey opened this Issue Oct 17, 2012 · 7 comments

Comments

Projects
None yet
4 participants
Contributor

kencausey commented Oct 17, 2012

With a current checkout of emacs (24.2.50) while trying to install starter-kit I get an error in starter-kit-misc.el. For now if I just comment out the references to hippie-expand-try-functions-list I seem to be able to get by. (I've seen this with versions on both Marmalade and MELPA.)

Debugger entered--Lisp error: (void-variable hippie-expand-try-functions-list)
(delete f hippie-expand-try-functions-list)
(while --dolist-tail-- (setq f (car --dolist-tail--)) (delete f hippie-expand-try-functions-list) (setq --dolist-tail-- (cdr --dolist-tail--)))
(let ((--dolist-tail-- (quote (try-expand-line try-expand-list try-complete-file-name-partially))) f) (while --dolist-tail-- (setq f (car --dolist-tail--)) (delete f hippie-expand-try-functions-list) (setq --dolist-tail-- (cdr --dolist-tail--))))
(progn (let ((--dolist-tail-- (quote (try-expand-line try-expand-list try-complete-file-name-partially))) f) (while --dolist-tail-- (setq f (car --dolist-tail--)) (delete f hippie-expand-try-functions-list) (setq --dolist-tail-- (cdr --dolist-tail--)))))
eval-buffer(#<buffer load-345082> nil "/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-misc.el" nil t) ; Reading at buffer position 4507
load-with-code-conversion("/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-misc.el" "/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-misc.el" nil t)
require(starter-kit-misc)
mapc(require (uniquify starter-kit-defuns starter-kit-misc))
eval-buffer(#<buffer load-408126> nil "/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-autoloads.el" nil t) ; Reading at buffer position 384
load-with-code-conversion("/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-autoloads.el" "/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-autoloads.el" nil t)
load("/home/ken/.emacs.d/elpa/starter-kit-20120518.1531/starter-kit-autoloads" nil t)
package--make-autoloads-and-compile("starter-kit" "/home/ken/.emacs.d/elpa/starter-kit-20120518.1531")
package-unpack(starter-kit "20120518.1531")
package-download-tar(starter-kit "20120518.1531")
package-download-transaction((magit ido-ubiquitous smex find-file-in-project idle-highlight-mode paredit starter-kit))
package-install(starter-kit)
(progn (package-install p))
(if (not (package-installed-p p)) (progn (package-install p)))
(while --dolist-tail-- (setq p (car --dolist-tail--)) (if (not (package-installed-p p)) (progn (package-install p))) (setq --dolist-tail-- (cdr --dolist-tail--)))
(let ((--dolist-tail-- my-packages) p) (while --dolist-tail-- (setq p (car --dolist-tail--)) (if (not (package-installed-p p)) (progn (package-install p))) (setq --dolist-tail-- (cdr --dolist-tail--))))
eval-buffer(#<buffer load> nil "/home/ken/.emacs.d/init.el" nil t) ; Reading at buffer position 945
load-with-code-conversion("/home/ken/.emacs.d/init.el" "/home/ken/.emacs.d/init.el" t t)
load("/home/ken/.emacs.d/init" t t)
#[0 "�\205\262

Contributor

kencausey commented Oct 17, 2012

Actually, I just added

(unless (boundp 'hippie-expand-try-functions-list)
(setq hippie-expand-try-functions-list '()))

immediately above the first use.

Contributor

dgutov commented Oct 17, 2012

You just need to (require 'hippie-exp) before the variable is first used.

Or, alternatively, wrap the whole hippie-expand-try-functions-list setup in (eval-after-load 'hippie-exp ...).

Contributor

kencausey commented Oct 17, 2012

Thanks! (mistakenly said: Requiring hippie-exp (in either form) doesn't change anything, I still get an error that hippie-expand-try-functions-list is a void variable.)

Contributor

kencausey commented Oct 17, 2012

Oops, compilation failure. Modifying starter-kit-misc.el to to use (eval-after-load 'hippie-exp ...) does address the problem.

thx for the tip, it worked now!
committers, please include this patch

Contributor

dgutov commented Nov 8, 2012

I think this can be closed now.

benbc commented Nov 22, 2012

I still see this problem with the version of the starter kit installed from Marmalade (2.0.3).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment