Permalink
Browse files

Upgrade to Ant 1.7.1 and exclude version from maven-ant-tasks

This is a personal itch, driven by a desire to use a task
incompatible with 1.6.5 [ant-deb-task].

Testing over the course of the day suggests that the problems
noted here:

http://groups.google.com/group/leiningen/browse_thread/thread/3a0118282d0394b0/a65645fca0f6f73c?lnk=gst&q=ant#a65645fca0f6f

don't seem to be happening anymore.

A brief attempt to use 1.8.1 ended in tears. Without doing much
research, it looks like lancet or leiningen will need to be
updated to work with that version.
  • Loading branch information...
1 parent 8c70303 commit 3a96bb10027b48dff0ed6031c32a0bf16c2a4c26 @travis travis committed with Oct 26, 2010
Showing with 3 additions and 2 deletions.
  1. +3 −2 project.clj
View
@@ -8,9 +8,10 @@
:license {:name "Eclipse Public License"}
:dependencies [[org.clojure/clojure "1.3.0-alpha1"]
[org.clojure.contrib/complete "1.3.0-alpha1" :classifier "bin"]
- [ant/ant "1.6.5"]
+ [ant/ant "1.7.1"]
@phirsch
phirsch Oct 26, 2010

I think this should be [org.apache.ant/ant "1.7.1"] - otherwise, maven complains about missing artifacts.

[jline "0.9.94"]
[robert/hooke "1.0.2"]
- [org.apache.maven/maven-ant-tasks "2.0.10"]]
+ [org.apache.maven/maven-ant-tasks "2.0.10"
+ :exclusions [ant/ant]]]
:disable-implicit-clean true
:eval-in-leiningen true)

1 comment on commit 3a96bb1

@travis
Collaborator
travis commented on 3a96bb1 Oct 26, 2010

oy - account juggling. that was me.

Please sign in to comment.