Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
74 lines (67 sloc) 2.16 KB
<?xml version="1.0" encoding="UTF-8"?>
<package version="2.1" xmlns="http://pear.php.net/dtd/package-2.1" xmlns:tasks="http://pear.php.net/dtd/tasks-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/dtd/tasks-1.0 http://pear.php.net/dtd/tasks-1.0.xsd http://pear.php.net/dtd/package-2.1 http://pear.php.net/dtd/package-2.1.xsd">
<name>LibRIS</name>
<channel>pear.querypath.org</channel>
<summary>LibRIS is a tool for parsing RIS data and data files.</summary>
<description/>
<lead>
<name>Matt Butcher</name>
<user>technosophos</user>
<email>matt@aleph-null.tv</email>
<active>yes</active>
</lead>
<date>2012-02-03</date>
<time>10:12:14</time>
<version>
<release>2.0.0</release>
<api>2.0.0</api>
</version>
<stability>
<release>stable</release>
<api>stable</api>
</stability>
<license uri="http://www.opensource.org/licenses/bsd-license.php">New BSD License</license>
<notes>LibRIS 2.0.
The 2.0.x branch is reorganized and now requires PHP 5.3 to properly
function.
It supports the following new features:
- Refactored library
- PSR-0 support for autoloading
- Packagist/Composer support.
LibRIS has been refactored to contain the following classes:
- \LibRIS\RISReader: Read RIS files.
- \LibRIS\RISWriter: Write RIS files.
- \LibRIS\RISTags: Tags and labels for RIS files.
- \LibRIS\ParseException: Thrown when parsing RIS fails.
</notes>
<contents>
<dir name="/">
<dir name="src" baseinstalldir="/">
<dir name="LibRIS">
<file role="php" name="ParseException.php"/>
<file role="php" name="RISReader.php"/>
<file role="php" name="RISTags.php"/>
<file role="php" name="RISWriter.php"/>
</dir>
</dir>
<dir name="tests" baseinstalldir="/">
<file role="test" name="Banyuls.ris"/>
<file role="test" name="derik-test.ris"/>
<file role="test" name="short.ris"/>
<file role="test" name="simple_test.php"/>
<file role="test" name="test1.ris"/>
</dir>
</dir>
</contents>
<dependencies>
<required>
<php>
<min>5.3.0</min>
</php>
<pearinstaller>
<min>2.0.0a1</min>
</pearinstaller>
</required>
</dependencies>
<phprelease/>
</package>