Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Support for Rails 3.2 #15

Open
wants to merge 6 commits into
from

Conversation

Projects
None yet
7 participants

No description provided.

firien and others added some commits Apr 19, 2011

Remove deprecation warnings.
- Removed several deprecation warnings on APIs like set_table_name
- Incorporated Behaviors InstanceMethods submodule methods into Behaviors
Upgrade to Rails 3.2 (still works on >= 3.0).
Made clone_versioned_model check for existence of versioned type columns.

Does actually the current version work on Rails 3.2.2? I have been able to install it but when I try to save a model I got

TypeError: can't convert String into Integer
from /Users/developer/.rvm/gems/ruby-1.9.3-p125@rails322/gems/activerecord-3.2.2/lib/active_record/attribute_methods/dirty.rb:63:in `[]='

The SQL queries work fineif I run them directly.

Thanks for any help.

@chuyihuang I'm using these patches in production without problems

Thank you and it works fine for me now.

zhublik commented Jan 18, 2013

I updated rails from 3.0 to 3.2.11 and when I run bundle update I got message:

Bundler could not find compatible versions for gem "activerecord":
In Gemfile:
rails (~> 3.2.11) ruby depends on
activerecord (= 3.2.11) ruby

acts_as_versioned (~> 0.6.0) ruby depends on
  activerecord (3.0.19)

Thanks for any help.

zhublik commented Jan 19, 2013

I add to gemfile source from github and problem was solved.

Is this project dead, considering that this pull request is over a year old, and the author has not even chimed in?

any fork for rails 4 support?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment