Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Files not properly "required" #3

Open
tricon opened this Issue · 0 comments

1 participant

David Aaron Fendley
David Aaron Fendley

When using attachment_fu alongside Yard, launching the Rails server throws an error that constant Technoweenie::AttachmentFu can not be found. It is failing on:

ActiveRecord::Base.send(:extend, Technoweenie::AttachmentFu::ActMethods)

When using attachment_fu alongside Shoulda, the same error is thrown when attempting to run tests.

In "init.rb", only TempFile and Geometry are required. Adding the following resolves the aforementioned issue, and should be added to the repo:

require 'technoweenie/attachment_fu'
Dir.glob(File.join(File.dirname(__FILE__), 'lib/backends/*.rb')).each {|f| require f }
Dir.glob(File.join(File.dirname(__FILE__), 'lib/processors/*.rb')).each {|f| require f }
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.