Permalink
Browse files

Unbundle tzinfo gem

Sadly, unpacking tzinfo into vendor gems breaks Rails' time zone
support and gives the following error when trying to access
admin/settings:

  uninitialized constant TZInfo::Timezone::TimezoneProxy

So we're going to instruct the user to install this gem using 'sudo
rake gems:install' for now.
  • Loading branch information...
1 parent 4f4e5a7 commit 6677a2c0f490a7cdaa1671482db3f714d45cf8d3 @emk emk committed Dec 22, 2008
Showing 621 changed files with 13 additions and 51,733 deletions.
View
@@ -4,7 +4,12 @@ release based on Rails 2.2.
/ Try to upgrade to gem version of coderay
/ Fix TZInfo to work again
/ Security audit--see below
- Fix script/generate
+/ Fix script/generate
+
+ Figure out why Mephisto won't work unless tzinfo is installed
+ Fix two intermittent comment failures in mephisto_controller_spec
+ Follow up on courtenay's BlueCloth patch
+
Make sure we know what's up with plugins
We need to review our TODO comments
View
@@ -43,6 +43,13 @@ <h2 style="margin: 10px 0">Installing Mephisto</h2>
freeze edge rails: <code>rake rails:freeze:edge</code></p>
<br />
+ <p>You will need to install the <code>tzinfo</code> gem using
+ the following command. For some reason, unpacking
+ the <code>tzinfo</code> gem into <code>vendor/gems</code>
+ breaks Rails' time-zone handling.</p>
+
+ <pre>sudo rake gems:install</pre>
+
<p>You can visit the <a href="http://mephistoblog.com/docs/setup">Mephisto install documentation</a> on the site to get the most recent content,
however for the impatient, here's the quick setup guide:</p>
<br />
Oops, something went wrong.

0 comments on commit 6677a2c

Please sign in to comment.