Permalink
Browse files

Add version numbers to config.gem statements

Let's just go ahead and require the minimum version of each gem that we
actually know works.  We also split out the test-specific gems into
their own section.
  • Loading branch information...
1 parent f580772 commit dfa982214629d3b6b9e43c1ff8e3ed3256d3899c @emk emk committed Dec 27, 2008
Showing with 11 additions and 9 deletions.
  1. +11 −9 config/environment.rb
View
@@ -77,18 +77,20 @@ def safe_to_load_application?
# We're slowly moving the contents of vendor and vender/plugins into
# vendor/gems by adding config.gem declarations.
config.gem 'RedCloth', :version => '3.0.4', :lib => 'redcloth'
- config.gem 'BlueCloth', :lib => 'bluecloth'
- config.gem 'faker'
- config.gem 'notahat-machinist', :lib => 'machinist',
- :source => 'http://gems.github.com'
- config.gem 'rubyzip', :lib => 'zip/zipfilesystem'
- config.gem 'liquid'
- config.gem 'will_paginate'
- config.gem 'mocha'
- config.gem 'coderay'
+ config.gem 'BlueCloth', :version => '>= 1.0.0', :lib => 'bluecloth'
+ config.gem 'rubyzip', :version => '>= 0.9.1', :lib => 'zip/zipfilesystem'
+ config.gem 'liquid', :version => '>= 1.9.0'
+ config.gem 'will_paginate', :version => '>= 2.2.2'
+ config.gem 'mocha', :version => '0.9.3'
+ config.gem 'coderay', :version => '0.8.260'
config.gem 'tzinfo', :version => '>= 0.3.12'
config.gem 'emk-safe_erb', :version => '>= 0.1.2', :lib => 'safe_erb',
:source => 'http://gems.github.com'
+
+ # These libraries are needed for our tests and specs.
+ config.gem 'faker', :version => '0.3.1'
+ config.gem 'notahat-machinist', :version => '0.1.2', :lib => 'machinist',
+ :source => 'http://gems.github.com'
config.gem 'nokogiri', :version => '>= 1.1.0' # Used by webrat.
config.gem 'brynary-webrat', :version => '>= 0.3.2.2', :lib => 'webrat',
:source => 'http://gems.github.com'

0 comments on commit dfa9822

Please sign in to comment.