Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Can't install #64

Closed
mikermcneil opened this Issue · 7 comments

3 participants

@mikermcneil

@techpines Hey Brad, I can't install asset rack at 2.1.4 or 2.1.5 right now via npm with a clean node_modules directory:

On the latest version of node and npm:

host081:sails mike$ npm -v
1.2.16
host081:sails mike$ node -v
v0.10.0
host081:sails mike$ 
npm WARN engine pkgcloud@0.6.6: wanted: {"node":"0.6.x || 0.8.x"} (current: {"node":"v0.10.0","npm":"1.2.16"})
npm ERR! Error: ENOENT, lstat '/code/sails/node_modules/asset-rack/node_modules/jade/LICENSE'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/jade/LICENSE
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/jade/LICENSE
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! Error: ENOENT, lstat '/code/sails/node_modules/asset-rack/node_modules/underscore/README.md'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/underscore/README.md
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/underscore/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! Error: ENOENT, chown '/code/sails/node_modules/asset-rack/node_modules/node-sassy/README.md'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/node-sassy/README.md
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/node-sassy/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chown
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:222:7
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/code/sails/node_modules/asset-rack/node_modules/browserify'
npm ERR! error rolling back  asset-rack@2.1.4 { [Error: ENOTEMPTY, rmdir '/code/sails/node_modules/asset-rack/node_modules/browserify']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/code/sails/node_modules/asset-rack/node_modules/browserify' }
npm ERR! Error: ENOENT, open '/code/sails/node_modules/asset-rack/node_modules/mime/package.json'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/mime/package.json
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! EEXIST, mkdir '/code/sails/node_modules/asset-rack/node_modules/nib'
File exists: /code/sails/node_modules/asset-rack/node_modules/nib
Move it away, and try again. 

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/nib
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/nib/History.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code EEXIST
npm ERR! errno 47
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:171:23
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/mkdirp/index.js:37:53
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! Error: ENOENT, lstat '/code/sails/node_modules/asset-rack/node_modules/coffee-script/README'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/coffee-script/README
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/coffee-script/README
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! Error: ENOENT, lstat '/code/sails/node_modules/asset-rack/node_modules/stylus/bm.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/stylus/bm.js
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/stylus/bm.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! Error: ENOENT, lstat '/code/sails/node_modules/asset-rack/node_modules/snockets/Cakefile'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/snockets/Cakefile
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/snockets/Cakefile
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! Error: ENOENT, lstat '/code/sails/node_modules/asset-rack/node_modules/pkgcloud/README.md'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Darwin 11.4.2
npm ERR! command "node" "/usr/local/bin/npm" "install" "asset-rack"
npm ERR! cwd /code/sails
npm ERR! node -v v0.10.0
npm ERR! npm -v 1.2.16
npm ERR! path /code/sails/node_modules/asset-rack/node_modules/pkgcloud/README.md
npm ERR! fstream_path /code/sails/node_modules/asset-rack/node_modules/pkgcloud/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:93:15)
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /code/sails/npm-debug.log
npm ERR! not ok code 0
host081:sails mike$ 
@mikermcneil

Same issue with:

host081:sails mike$ sudo npm install asset-rack@git://github.com/techpines/asset-rack.git
@mikermcneil

Seems like it was a system specific issue. To solve it, I ended up deleting ~/.npm, in case that helps anyone else out!

-mm

@mikermcneil mikermcneil closed this
@techpines
Owner

Oh happy day! Npm cache issue :)

@leehambley

@mikermcneil thanks for your comment, I ran into this today, could not figure out why, had no idea this could be ~/.npm related. (Didn't even know that directory existed until now)

@mikermcneil

Np- running npm cache clear sometimes helps as well. Maybe just set them both up as an alias: fuuuu

@leehambley

Maybe just set them both up as an alias: fuuuu

The :trophy: for the best improvement to my node.js experience goes to @mikermcneil.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.