Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Uncaught ReferenceError: Invalid left-hand side expression in postfix operation #19

Closed
fredw opened this Issue · 3 comments

3 participants

@fredw

Hi!

When I shrink this file: https://gist.github.com/fredw/4756686
Returns the following error when running the plugin: Uncaught ReferenceError: Invalid left-hand side expression in postfix operation

Thanks in advance

@Danack

Hi,

I'm seeing the same issue. I've isolated the issue; It's caused by a missing space between plus signs in the already minified version of jquery-ui.min

An example can be seen at http://jsfiddle.net/Danack/scU3v/

Original jQuery: ( "ui-id-" + (++uuid);
jQuery min: ("ui-id-"+ ++n);
jShrinked: ("ui-id-"+++n);

This generates a "Invalid left-hand side expression in postfix operation".

While it would be good to fix this, for anyone else encountering the error, it appears you can work around it by changing the jQuery min to ("ui-id-"+ (++n));

@fredw

This works!
Thanks.

@tedivm
Owner

This should now be resolved in JShrink without the need to modify code.

@tedivm tedivm closed this
@tazzydemon tazzydemon referenced this issue in silverstripe/silverstripe-framework
Open

JQuery UI failure with Requirements:combine_files #3126

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.