Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 35 lines (30 sloc) 1.081 kB
1cb5f21 @y8 First version
y8 authored
1 require 'rake'
2 require 'rake/testtask'
755e076 @gzigzigzeo Add jeweler, Gemfile and specs
gzigzigzeo authored
3 require 'rspec/core'
4 require 'rspec/core/rake_task'
1cb5f21 @y8 First version
y8 authored
5
755e076 @gzigzigzeo Add jeweler, Gemfile and specs
gzigzigzeo authored
6 RSpec::Core::RakeTask.new(:spec)
7 task :default => :spec
8
9 begin
10 include_files = ["README*", "LICENSE", "Rakefile", "init.rb", "{lib,test}/**/*"].map do |glob|
11 Dir[glob]
12 end.flatten
13
14 require "jeweler"
15 Jeweler::Tasks.new do |s|
16 s.name = "paperclip-meta"
17 s.version = "0.1"
18 s.author = "Alexey Bondar"
19 s.email = "y8@ya.ru"
20 s.homepage = "http://github.com/y8/paperclip-meta"
21 s.description = "Add width, height and size methods to paperclip thumbnails"
22 s.summary = "Thumbnail dimensions for paperclip"
23 s.platform = Gem::Platform::RUBY
24 s.files = include_files
25 s.require_path = "lib"
26 s.rubyforge_project = "paperclip-meta"
27 s.has_rdoc = false
28 s.add_dependency 'paperclip'
29 end
30
31 Jeweler::GemcutterTasks.new
32 rescue LoadError
33 puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
1cb5f21 @y8 First version
y8 authored
34 end
Something went wrong with that request. Please try again.