Permalink
Browse files

Fix failing tests on jruby

  • Loading branch information...
y8 committed Mar 5, 2012
1 parent 9343ec6 commit dc2c81c9d70475de7c3357219fc5418480bb3b28
Showing with 23 additions and 13 deletions.
  1. +2 −0 Gemfile
  2. +20 −13 Gemfile.lock
  3. +1 −0 paperclip-meta.gemspec
View
@@ -1,4 +1,6 @@
source "http://rubygems.org"
+gem "activerecord-jdbcsqlite3-adapter", :platform => "jruby"
+
# Specify your gem's dependencies in paperclip-meta.gemspec
gemspec
View
@@ -1,36 +1,41 @@
PATH
remote: .
specs:
- paperclip-meta (0.4.0)
+ paperclip-meta (0.4.1)
paperclip
GEM
remote: http://rubygems.org/
specs:
- activemodel (3.2.0)
- activesupport (= 3.2.0)
+ activemodel (3.2.2)
+ activesupport (= 3.2.2)
builder (~> 3.0.0)
- activerecord (3.2.0)
- activemodel (= 3.2.0)
- activesupport (= 3.2.0)
- arel (~> 3.0.0)
+ activerecord (3.2.2)
+ activemodel (= 3.2.2)
+ activesupport (= 3.2.2)
+ arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activesupport (3.2.0)
+ activerecord-jdbc-adapter (1.2.2)
+ activerecord-jdbcsqlite3-adapter (1.2.2)
+ activerecord-jdbc-adapter (~> 1.2.2)
+ jdbc-sqlite3 (~> 3.7.2)
+ activesupport (3.2.2)
i18n (~> 0.6)
multi_json (~> 1.0)
- arel (3.0.0)
+ arel (3.0.2)
builder (3.0.0)
cocaine (0.2.1)
diff-lcs (1.1.3)
i18n (0.6.0)
+ jdbc-sqlite3 (3.7.2)
mime-types (1.17.2)
- multi_json (1.0.4)
- paperclip (2.5.0)
+ multi_json (1.1.0)
+ paperclip (2.7.0)
activerecord (>= 2.3.0)
activesupport (>= 2.3.2)
cocaine (>= 0.0.2)
mime-types
- rake (0.8.7)
+ rake (0.9.2.2)
rspec (2.8.0)
rspec-core (~> 2.8.0)
rspec-expectations (~> 2.8.0)
@@ -42,13 +47,15 @@ GEM
sqlite3 (1.3.5)
sqlite3-ruby (1.3.3)
sqlite3 (>= 1.3.3)
- tzinfo (0.3.31)
+ tzinfo (0.3.32)
PLATFORMS
+ java
ruby
DEPENDENCIES
activerecord
+ activerecord-jdbcsqlite3-adapter
bundler (>= 1.0.0)
paperclip
paperclip-meta!
View
@@ -24,6 +24,7 @@ Gem::Specification.new do |s|
s.add_development_dependency "paperclip"
s.add_development_dependency "rspec"
s.add_development_dependency "activerecord"
+ s.add_development_dependency "activerecord-jdbcsqlite3-adapter" if RUBY_PLATFORM == 'java'
s.add_development_dependency "sqlite3-ruby"
# Runtime dependencies

0 comments on commit dc2c81c

Please sign in to comment.