Errors with Paperclip 3.0.1 #11

Closed
dce opened this Issue Apr 1, 2012 · 5 comments

Projects

None yet

5 participants

Contributor
dce commented Apr 1, 2012

I'm encountering errors when attempting to use this lib with the latest version of Paperclip (3.0.1). Namely:

NameError: uninitialized constant Paperclip::Meta::Attachment::InstanceMethods::NotIdentifiedByImageMagickError

(originating from line 37 of attachment.rb). If I change that to:

rescue Paperclip::Errors::NotIdentifiedByImageMagickError => e

I get:

TypeError: can't convert Paperclip::FileAdapter into String

(originating from line 36 of the same file). If I change that to:

meta[style] = {:width => geo.width.to_i, :height => geo.height.to_i, :size => file.size }

then things seem to work as expected. I tried to put together a pull request, but I get different errors when I update paperclip and then run the specs.

Can confirm I'm having the same issue

Contributor
dce commented Apr 3, 2012

Pull request submitted: #13

jrreed commented Apr 4, 2012

Yup, same problem here.
@dce - you're fix resolved the issue for me

Is this still an issue? The pull request was merged, but I am wondering now whether this will work with Paperclip 3.0.2 or not?

Owner

Closing as stale.

@teeparham teeparham closed this Feb 1, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment