New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error with Homebrew install #275

Closed
dylanscott opened this Issue Aug 29, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@dylanscott

dylanscott commented Aug 29, 2017

I previously was able to install telepresence via homebrew without issue, but now when try I get the following output:

$ brew install datawire/blackbird/telepresence
==> Installing telepresence from datawire/blackbird
Error: datawire/blackbird/telepresence contains conflicting version recursive dependencies:
  openssl, openssl@1.1
View these with `brew deps --tree datawire/blackbird/telepresence`.

Running the recommended deps command yields:

$ brew deps --tree datawire/blackbird/telepresence
datawire/blackbird/telepresence (required dependencies)
├── python3
│   ├── pkg-config
│   ├── sphinx-doc
│   ├── openssl
│   │   └── makedepend
│   │       └── pkg-config
│   ├── readline
│   ├── sqlite
│   │   └── readline
│   ├── gdbm
│   └── xz
├── torsocks
│   ├── :git
│   ├── autoconf
│   ├── automake
│   │   └── autoconf
│   └── libtool
├── sshfs
│   ├── pkg-config
│   ├── autoconf
│   ├── automake
│   │   └── autoconf
│   ├── libtool
│   └── glib
│       ├── pkg-config
│       ├── autoconf
│       ├── automake
│       │   └── autoconf
│       ├── libtool
│       ├── gettext
│       ├── libffi
│       └── pcre
└── socat
    ├── openssl@1.1
    └── readline

It looks like the socat formula was recently updated to depend on openssl@1.1, which conflicts with python3's openssl dependency.

I don't know enough about homebrew to know what can be done about this.

@dylanscott

This comment has been minimized.

dylanscott commented Aug 29, 2017

Also apologies if this would have made more sense to file on the datawire/homebrew-blackbird repo

@ark3

This comment has been minimized.

Contributor

ark3 commented Aug 29, 2017

Thanks for chasing this down. I released 0.65 that removes the socat dependency to work around this.

@ark3 ark3 closed this Aug 29, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment