Permalink
Browse files

Prepare for 3.0.4 release. Change AR dependency to lock down to >= 3.…

…0.0 and less than 3.1.0 in preparation for new Arel conflicts.
  • Loading branch information...
metaskills committed Oct 26, 2010
1 parent 40ef676 commit 468ef64eb1d5d586568ce406ee06f9bb1b7d3cac
View
@@ -1,4 +1,5 @@
-* master *
+
+* 3.0.4 *
* Add multiple results set support with #execute_procedure for :dblib mode. [Ken Collins]
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
s.name = "activerecord-sqlserver-adapter"
- s.version = "3.0.3"
+ s.version = "3.0.4"
s.summary = "SQL Server 2005 and 2008 Adapter For ActiveRecord."
s.description = "SQL Server 2005 and 2008 Adapter For ActiveRecord"
@@ -17,6 +17,6 @@ Gem::Specification.new do |s|
s.rdoc_options.concat ['--main', 'README.rdoc']
s.rubyforge_project = 'activerecord-sqlserver-adapter'
- s.add_dependency('activerecord', '~> 3.0')
+ s.add_dependency('activerecord', '~> 3.0.0')
end
@@ -163,7 +163,7 @@ class SQLServerAdapter < AbstractAdapter
include Sqlserver::Errors
ADAPTER_NAME = 'SQLServer'.freeze
- VERSION = '3.0.3'.freeze
+ VERSION = '3.0.4'.freeze
DATABASE_VERSION_REGEXP = /Microsoft SQL Server\s+(\d{4})/
SUPPORTED_VERSIONS = [2005,2008].freeze

0 comments on commit 468ef64

Please sign in to comment.