Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

adding rakefile and regenerating gemspec

  • Loading branch information...
commit 587f2a99e55e8a0bad95babc576b73dee3cdeeed 1 parent 50bce1d
@tenderlove authored
Showing with 24 additions and 7 deletions.
  1. +10 −1 Rakefile
  2. +14 −6 meow.gemspec
View
11 Rakefile
@@ -6,10 +6,19 @@ require './vendor/hoe.rb'
$LOAD_PATH << File.join(File.dirname(__FILE__), 'lib')
require 'meow'
-Hoe.new('meow', Meow::VERSION) do |p|
+HOE = Hoe.new('meow', Meow::VERSION) do |p|
p.readme = 'README.rdoc'
p.history = 'CHANGELOG.rdoc'
p.developer('Aaron Patterson', 'aaronp@rubyforge.org')
end
+namespace :gem do
+ task :spec do
+ File.open("#{HOE.name}.gemspec", 'w') do |f|
+ HOE.spec.version = "#{HOE.version}.#{Time.now.strftime("%Y%m%d%H%M%S")}"
+ f.write(HOE.spec.to_ruby)
+ end
+ end
+end
+
# vim: syntax=Ruby
View
20 meow.gemspec
@@ -1,22 +1,30 @@
Gem::Specification.new do |s|
s.name = %q{meow}
- s.version = "1.1.0"
-
- s.specification_version = 2 if s.respond_to? :specification_version=
+ s.version = "2.1.0.20081101124146"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Aaron Patterson"]
- s.date = %q{2008-06-05}
+ s.date = %q{2008-11-01}
s.description = %q{Send Growl notifications via Ruby.}
s.email = ["aaronp@rubyforge.org"]
s.extra_rdoc_files = ["Manifest.txt"]
- s.files = ["CHANGELOG.rdoc", "Manifest.txt", "README.rdoc", "Rakefile", "lib/meow.rb", "meow.gemspec", "test/helper.rb", "test/test_meow.rb", "vendor/hoe.rb"]
+ s.files = [".autotest", "CHANGELOG.rdoc", "Manifest.txt", "README.rdoc", "Rakefile", "icons/fail.png", "icons/initialize.jpeg", "icons/pass.png", "lib/meow.rb", "lib/meow/autotest.rb", "lib/meow/notifier.rb", "meow.gemspec", "test/assets/aaron.jpeg", "test/helper.rb", "test/test_meow.rb", "vendor/hoe.rb"]
s.has_rdoc = true
s.homepage = %q{http://meow.rubyforge.org/}
s.rdoc_options = ["--main", "README.rdoc"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{meow}
- s.rubygems_version = %q{1.1.1}
+ s.rubygems_version = %q{1.2.0}
s.summary = %q{Send Growl notifications via Ruby.}
s.test_files = ["test/test_meow.rb"]
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 2
+
+ if current_version >= 3 then
+ else
+ end
+ else
+ end
end
Please sign in to comment.
Something went wrong with that request. Please try again.