Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Install documentation, fixes #91

  • Loading branch information...
commit 3e3935b62398cf0eaf3b3f50c3f3aa99ad914f5a 1 parent 4be2aef
@zzak zzak authored
Showing with 22 additions and 2 deletions.
  1. +22 −2 README.rdoc
View
24 README.rdoc
@@ -23,8 +23,28 @@ to and from the YAML format.
== Installation
-* sudo port install libyaml +universal
-* sudo install_ruby.sh
+Psych has been included with MRI since 1.9.2,
+and is the fault YAML parser in 1.9.3.
+
+If you want a newer gem release of Psych, you can use rubygems:
+
+ gem install psych
+
+In order to use the gem release in your app,
+and not the stdlib version, you'll need the following:
+
+ gem 'psych'
+ require 'psych'
+
+Or if you use Bundler add this to your +Gemfile+:
+
+ gem 'psych'
+
+JRuby ships with a pure Java implementation of Psych.
+
+If you're on Rubinius, Psych is available in 1.9 mode, please refer to the
+{Rubinius Documentation}[http://rubini.us/doc/en/build-system/] for more
+information on building and 1.9 mode.
== License
Please sign in to comment.
Something went wrong with that request. Please try again.