Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Install documentation #91

Closed
zzak opened this Issue · 7 comments

3 participants

@zzak
Collaborator

The current installation documentation seems wrong.

Should we mention Ruby > 1.9.2 already includes psych?

What about older rubies? Would the gem release cover those, and people wanting newer functionality?

Is it worth bothering to mention how to install the dependencies for each OS/distro?

@tenderlove
Owner

Probably we should mention the ruby's that include psych. I expect psych to work on 1.9.2+. I'm not really interested in making it work on 1.8. We possibly could, but it seems like lots of work.

I'm not sure we should bother about how to install the dependencies for each OS/distro. I'm pretty sure the number of possible ways to install libyaml are too great.

Do you have suggestions?

@zzak
Collaborator

I'm not really interested in making it work on 1.8

If that's the case, then let's just mention psych's inclusion in 1.9.2+.

What about other ruby implementations, like jruby / rubinius / etc? Do they have psych? If so which versions are relevant to the psych timeline?

How about this:

== Installation

Psych has been included with MRI since 1.9.2, and is the default YAML parser in 1.9.3.

If you want a newer gem release of Psych, you can use rubygems:

    gem install psych

I would mention other ruby implementations here.
@tenderlove
Owner

JRuby ships with a pure Java implementation, but I'm not shipping that yet (it's on the todo list). Right now shipping a stdlib gem for JRuby is not easy. As for rbx, I'm not sure. I don't think they ship with psych. All of the C code should be supported by rbx, but I'm not sure about the Ruby code (since there is some 1.9 specific stuff).

@zzak
Collaborator

@brixen can you comment on this?

As for rbx, I'm not sure. I don't think they ship with psych. All of the C code should be supported by rbx, but I'm not sure about the Ruby code (since there is some 1.9 specific stuff).

@brixen

Rubinius merely imports the Psych C extension from MRI. We require that libyaml be installed to build Rubinius in 1.9 mode.

@zzak
Collaborator

For the record, rbx currently has psych 1.3.2, I just tested this myself:

https://gist.github.com/3916170

I was able to gem install psych 1.3.4, but I'm unable to use it with rbx; this should probably be reported to rubinius. Otherwise, things look good; I'm able to use the psych that ships with rbx and build newer releases of the psych gem.

@zzak
Collaborator

I was able to gem install psych 1.3.4, but I'm unable to use it with rbx; this should probably be reported to rubinius.

Nevermind, I think this is an rvm issue. :disappointed:

@zzak zzak referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
@tenderlove tenderlove closed this in 3e3935b
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.