Skip to content

add missing #warn in #init_with for #yaml_initialize deprecation #53

Merged
merged 1 commit into from Mar 23, 2012
View
2 lib/psych/visitors/to_ruby.rb
@@ -285,7 +285,7 @@ def init_with o, h, node
o.init_with c
elsif o.respond_to?(:yaml_initialize)
if $VERBOSE
- "Implementing #{o.class}#yaml_initialize is deprecated, please implement \"init_with(coder)\""
+ warn "Implementing #{o.class}#yaml_initialize is deprecated, please implement \"init_with(coder)\""
end
o.yaml_initialize c.tag, c.map
else
Something went wrong with that request. Please try again.