Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Rails 3.2.x #8

Closed
wants to merge 8 commits into from

2 participants

@softcraft-development

Hi there. I'm in the process of upgrading my app to Rails 3.2, and so I needed a version of the rails_autolink gem that had the right dependencies. I've tested with Rails 3.2.0 and 3.2.1 and found it to pass in both cases.

In order to get bundler working right and pulling from github, I added a gemspec into the codebase. I know you don't want a gemspec in the code itself, you'll probably want to ignore my actual pull request and just update the dependencies yourself.

@xuanxu
Collaborator

I've pushed a new version with the dependencies changed to include rails 3.2.
Thanks!

@xuanxu xuanxu closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 44 additions and 2 deletions.
  1. +1 −1  Rakefile
  2. +1 −1  lib/rails_autolink.rb
  3. +42 −0 rails_autolink.gemspec
View
2  Rakefile
@@ -15,7 +15,7 @@ Hoe.spec 'rails_autolink' do
self.readme_file = 'README.rdoc'
self.history_file = 'CHANGELOG.rdoc'
self.extra_rdoc_files = FileList['*.rdoc']
- self.extra_deps << ['rails', '~> 3.1.0']
+ self.extra_deps << ['rails', '>= 3.1', '<= 3.2.1']
end
# vim: syntax=ruby
View
2  lib/rails_autolink.rb
@@ -1,5 +1,5 @@
module RailsAutolink
- VERSION = '1.0.3'
+ VERSION = '1.0.3.1'
class Railtie < ::Rails::Railtie
initializer 'rails_autolink' do |app|
View
42 rails_autolink.gemspec
@@ -0,0 +1,42 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = "rails_autolink"
+ s.version = "1.0.3.1.20120127181656"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Aaron Patterson", "Juanjo Bazan", "Akira Matsuda"]
+ s.date = "2012-01-27"
+ s.description = "This is an extraction of the `auto_link` method from rails. The `auto_link`\nmethod was removed from Rails in version Rails 3.1. This gem is meant to\nbridge the gap for people migrating."
+ s.email = ["aaron@tenderlovemaking.com", "jjbazan@gmail.com", "ronnie@dio.jp"]
+ s.extra_rdoc_files = ["Manifest.txt", "CHANGELOG.rdoc", "README.rdoc"]
+ s.files = [".autotest", "CHANGELOG.rdoc", "Gemfile", "Manifest.txt", "README.rdoc", "Rakefile", "lib/rails_autolink.rb", "lib/rails_autolink/helpers.rb", "test/test_rails_autolink.rb"]
+ s.homepage = "http://github.com/tenderlove/rails_autolink"
+ s.rdoc_options = ["--main", "README.rdoc"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = "rails_autolink"
+ s.rubygems_version = "1.8.15"
+ s.summary = "This is an extraction of the `auto_link` method from rails"
+ s.test_files = ["test/test_rails_autolink.rb"]
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<rails>, ["<= 3.2.1", ">= 3.1"])
+ s.add_development_dependency(%q<minitest>, ["~> 2.11"])
+ s.add_development_dependency(%q<rdoc>, ["~> 3.10"])
+ s.add_development_dependency(%q<hoe>, ["~> 2.13"])
+ else
+ s.add_dependency(%q<rails>, ["<= 3.2.1", ">= 3.1"])
+ s.add_dependency(%q<minitest>, ["~> 2.11"])
+ s.add_dependency(%q<rdoc>, ["~> 3.10"])
+ s.add_dependency(%q<hoe>, ["~> 2.13"])
+ end
+ else
+ s.add_dependency(%q<rails>, ["<= 3.2.1", ">= 3.1"])
+ s.add_dependency(%q<minitest>, ["~> 2.11"])
+ s.add_dependency(%q<rdoc>, ["~> 3.10"])
+ s.add_dependency(%q<hoe>, ["~> 2.13"])
+ end
+end
Something went wrong with that request. Please try again.