Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Show all assets files available in gem on site #362

Open
westonganger opened this issue Jun 23, 2016 · 4 comments

Comments

Projects
None yet
3 participants
@westonganger
Copy link

commented Jun 23, 2016

The old sites design used to list all available files that I could manually include. I consistently find myself missing this feature with the new site. Would be nice if you could somehow add this list into the new sites design.

@hut8

This comment has been minimized.

Copy link
Member

commented Jun 23, 2016

Hey @westonganger ! Thanks very much for the feedback. Are you talking about where it used to show up like this, except with the correct scripts?

wut

If so, the reason for the change was that you should only need to include what is directed by the new design. However, we recognize that many (if not most) people who make bower packages don't necessarily include this correctly. Can you give us one specific example of where you needed to look it up? That would help us improve it. Of course, PRs are definitely welcome.

@westonganger

This comment has been minimized.

Copy link
Author

commented Jun 23, 2016

Yes, the All scripts and All stylesheets sections.

@westonganger

This comment has been minimized.

Copy link
Author

commented Jun 23, 2016

This repo for example https://github.com/ceolter/ag-grid

I am guessing you build from main.js or something. This one fails because it is looking for a common js require. If I could access the dist folder then I could just correctly require the dist files that I need.

Another use case for this could be an optional theme stylesheet or something like that.

@hut8 hut8 referenced this issue Sep 12, 2016

Closed

isotope is borked #376

@sethherr

This comment has been minimized.

Copy link

commented Oct 12, 2016

This would be great - if I want to include additional themes I have to dig around. And stylesheets don't ever seem to be included in the list.

For swagger-ui, I had to add the scss file -

// application.scss
*= require swagger-ui/dist/css/style.scss

And I gave up before I managed to get the swagger js to all work. Requiring their version of backbone made sprockets expliode - //= require swagger-ui/lib/backbone-min.js

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.