Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed install on Windows #16478

Closed
duxingzhe opened this Issue Jan 27, 2018 · 15 comments

Comments

Projects
None yet
10 participants
@duxingzhe
Copy link

duxingzhe commented Jan 27, 2018

Python 3.6.4

There is a strange error when I install tensorflow 1.5.

Collecting tensorflow
  Using cached https://pypi.tuna.tsinghua.edu.cn/packages/34/96/11f048eca7b4d6da3084ca49c636b9e720e9dd1483c0c4e9ba3cf5037564/tensorflow-1.5.0-cp36-cp36m-win_amd64.whl
Requirement already up-to-date: wheel>=0.26 in d:\python\python36\lib\site-packages (from tensorflow)
Requirement already up-to-date: numpy>=1.12.1 in d:\python\python36\lib\site-packages (from tensorflow)
Collecting absl-py>=0.1.6 (from tensorflow)
  Using cached https://pypi.tuna.tsinghua.edu.cn/packages/42/3c/1985d86a44bfe44fd060c02807336f840a509bfaa2d340860fba7d22da39/absl-py-0.1.9.tar.gz
Requirement already up-to-date: protobuf>=3.4.0 in d:\python\python36\lib\site-packages (from tensorflow)
Requirement already up-to-date: six>=1.10.0 in d:\python\python36\lib\site-packages (from tensorflow)
Collecting tensorflow-tensorboard<1.6.0,>=1.5.0 (from tensorflow)
  Using cached https://pypi.tuna.tsinghua.edu.cn/packages/43/69/82e2a368076c94edbba3cd15804103bf1f31486d69e11551b71fa1d1f384/tensorflow_tensorboard-1.5.0-py3-none-any.whl
Requirement already up-to-date: setuptools in d:\python\python36\lib\site-packages (from protobuf>=3.4.0->tensorflow)
Requirement already up-to-date: bleach==1.5.0 in d:\python\python36\lib\site-packages (from tensorflow-tensorboard<1.6.0,>=1.5.0->tensorflow)
Requirement already up-to-date: markdown>=2.6.8 in d:\python\python36\lib\site-packages (from tensorflow-tensorboard<1.6.0,>=1.5.0->tensorflow)
Requirement already up-to-date: werkzeug>=0.11.10 in d:\python\python36\lib\site-packages (from tensorflow-tensorboard<1.6.0,>=1.5.0->tensorflow)
Requirement already up-to-date: html5lib==0.9999999 in d:\python\python36\lib\site-packages (from tensorflow-tensorboard<1.6.0,>=1.5.0->tensorflow)
Collecting futures>=3.1.1 (from tensorflow-tensorboard<1.6.0,>=1.5.0->tensorflow)
  Using cached https://pypi.tuna.tsinghua.edu.cn/packages/1f/9e/7b2ff7e965fc654592269f2906ade1c7d705f1bf25b7d469fa153f7d19eb/futures-3.2.0.tar.gz
Unknown requires Python '>=2.6, <3' but the running Python is 3.6.4

Why the dependency is futures? It doesn't have a verion of Python 3.6.4.

@tatianashp

This comment has been minimized.

Copy link
Member

tatianashp commented Jan 27, 2018

It is hard to understand your problem without complete information. What installation method do you use?

@fpsandnoob

This comment has been minimized.

Copy link

fpsandnoob commented Jan 27, 2018

I have a same problem on the Ubuntu 16.04. I use pip to get the Python 3.5 binary file. And it is strange that Python 3 doesn't need the futures package.

@tatianashp

This comment has been minimized.

Copy link
Member

tatianashp commented Jan 27, 2018

@fpsandnoob Could you please specify what method you use to install TensorFlow?

@fpsandnoob

This comment has been minimized.

Copy link

fpsandnoob commented Jan 27, 2018

@tatianashp I used the native pip to install tensorflow-gpu with the version of Python 3.5. When the pip install the dependency, the problem occurred. Like this one:
pip install --ignore-installed --upgrade https://storage.googleapis.com/tensorflow/linux/gpu/tensorflow_gpu-1.5.0-cp35-cp35m-linux_x86_64.whl

@WongChen

This comment has been minimized.

Copy link

WongChen commented Jan 27, 2018

Same problem here on Ubuntu 16.04 with Python 3.5.
Clearly, Python 3 doesn't need futures. And with Python 2.7, using :
pip2 install tensorflow-gpu==1.5.0
it goes well.
Here's a solution for Python 3:
The error is occurred when installing the version of futures 3.2.0 for Python 3. It is noticed that:

It should not be installed on Python 3, although there should be no harm in doing so, as the standard library takes precedence over third party libraries.

First, install futures 3.1.1:

pip3 install futures==3.1.1
then :
pip3 install tensorflow-gpu==1.5.0
Do not add the --ignore-installed or -I

@duxingzhe

This comment has been minimized.

Copy link
Author

duxingzhe commented Jan 27, 2018

Thanks for previous solution.

@duxingzhe duxingzhe closed this Jan 27, 2018

@pokey

This comment has been minimized.

Copy link

pokey commented Jan 29, 2018

I think this issue should be reopened. @WongChen has posted a workaround, but this is still a bug in tensorflow's dependency setup, is it not?

@HustCoderHu

This comment has been minimized.

Copy link

HustCoderHu commented Jan 30, 2018

agree with pokey, this is a bug

@zsrkmyn

This comment has been minimized.

Copy link

zsrkmyn commented Jan 30, 2018

agree with @pokey, I think it's a bug as well.

@dgun-y

This comment has been minimized.

Copy link

dgun-y commented Jan 30, 2018

i'd argue this is more a problem with futures, not with TF since TF's requirement with futures is 3.1.1+ which works fine on Python3.6

@WongChen

This comment has been minimized.

Copy link

WongChen commented Jan 30, 2018

I think the problem here is that futures > 3.1.1 is not allowed to be installed for py3.
see here.
Since pip install the newest version, the error is occurred.
If you google it, you can find many errors just like this.
On the other side, I think tf for py3 package's dependency should not include futures.

@dgun-y

This comment has been minimized.

Copy link

dgun-y commented Jan 30, 2018

ah, my bad. i assumed that it was ok to install futures 3.1.1 for python 3 but seems like they just forgot to check the version.

@tatianashp

This comment has been minimized.

Copy link
Member

tatianashp commented Jan 31, 2018

@chihuahua Could you please take a look at tensorboard dependency on futures?

@yaox12

This comment has been minimized.

Copy link
Contributor

yaox12 commented Jan 31, 2018

I think the problem is caused by tensorboard dependency, it requires futures >= 3.1.1.

Collecting futures>=3.1.1 (from tensorflow-tensorboard<1.6.0,>=1.5.0->tensorflow)
futures requires Python '>=2.6, <3' but the running Python is 3.6.4

@tatianashp

This comment has been minimized.

Copy link
Member

tatianashp commented Feb 1, 2018

@yaox12 You are correct. It is tensorboard issue. See tensorflow/tensorboard/#916. tensorflow/tensorboard/#920 PR fixes the problem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.