Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tensorflow 1.13.0 reports wrong version #26046

Closed
beew opened this issue Feb 24, 2019 · 12 comments

Comments

@beew
Copy link

@beew beew commented Feb 24, 2019

System information

  • OS Platform and Distribution: Linux Ubuntu 16.04
  • TensorFlow installed from: source
  • TensorFlow version: 1.13.0
  • Python version: 3.5.2
  • Bazel version : 0.22.0
  • GCC/Compiler version (if compiling from source): 5.4.0
  • CUDA/cuDNN version: cuda10.0 cudnn7.4.2.24
  • GPU model and memory: GTX1070

Tensorflow compiled and built without issue. But when created wheel with command

 ./bazel-bin/tensorflow/tools/pip_package/build_pip_package $HOME/opt/cuda_test/cuda10/tensorflow_pkg

The wheel created was called tensorflow-1.12.0-cp35-cp35m-linux_x86_64.whl

I changed 1.12.0 to 1.13.0 manually and install it with pip

cd $HOME/tensorflow_pkg
pip3 install --no-cache-dir ./tensorflow-1.13.0-cp35-cp35m-linux_x86_64.whl --user
Processing ./tensorflow-1.13.0-cp35-cp35m-linux_x86_64.whl
Requirement already satisfied: absl-py>=0.1.6 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (0.7.0)
Requirement already satisfied: keras-preprocessing>=1.0.5 in /usr/local/lib/python3.5/dist-packages (from tensorflow==1.13.0) (1.0.5)
Requirement already satisfied: six>=1.10.0 in /usr/local/lib/python3.5/dist-packages (from tensorflow==1.13.0) (1.11.0)
Requirement already satisfied: keras-applications>=1.0.6 in /usr/local/lib/python3.5/dist-packages (from tensorflow==1.13.0) (1.0.6)
Requirement already satisfied: google-pasta>=0.1.2 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (0.1.4)
Requirement already satisfied: gast>=0.2.0 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (0.2.2)
Requirement already satisfied: protobuf>=3.6.1 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (3.6.1)
Requirement already satisfied: numpy<2.0,>=1.14.5 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (1.16.1)
Requirement already satisfied: grpcio>=1.8.6 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (1.18.0)
Requirement already satisfied: wheel>=0.26 in /usr/local/lib/python3.5/dist-packages (from tensorflow==1.13.0) (0.31.1)
Requirement already satisfied: tensorflow-estimator<1.14.0rc0,>=1.13.0rc0 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (1.13.0rc0)
Requirement already satisfied: termcolor>=1.1.0 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (1.1.0)
Requirement already satisfied: astor>=0.6.0 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (0.7.1)
Requirement already satisfied: tensorboard<1.13.0,>=1.12.0 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorflow==1.13.0) (1.12.2)
Requirement already satisfied: h5py in /usr/local/lib/python3.5/dist-packages (from keras-applications>=1.0.6->tensorflow==1.13.0) (2.9.0)
Requirement already satisfied: setuptools in /usr/local/lib/python3.5/dist-packages (from protobuf>=3.6.1->tensorflow==1.13.0) (40.8.0)
Requirement already satisfied: mock>=2.0.0 in /usr/local/lib/python3.5/dist-packages (from tensorflow-estimator<1.14.0rc0,>=1.13.0rc0->tensorflow==1.13.0) (2.0.0)
Requirement already satisfied: werkzeug>=0.11.10 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorboard<1.13.0,>=1.12.0->tensorflow==1.13.0) (0.14.1)
Requirement already satisfied: markdown>=2.6.8 in /home/bernard/opt/cuda_test/cuda10/lib/python3.5/site-packages (from tensorboard<1.13.0,>=1.12.0->tensorflow==1.13.0) (3.0.1)
Requirement already satisfied: pbr>=0.11 in /usr/local/lib/python3.5/dist-packages (from mock>=2.0.0->tensorflow-estimator<1.14.0rc0,>=1.13.0rc0->tensorflow==1.13.0) (4.0.4)
Installing collected packages: tensorflow
**Successfully installed tensorflow-1.12.0**

From last sentence of ouput above python still sees tensorflow-1.12.0

Now

$ python3
Python 3.5.2 (default, Nov 12 2018, 13:43:14) 
[GCC 5.4.0 20160609] on linux
Type "help", "copyright", "credits" or "license" for more information.

import tensorflow as tf
Limited tf.compat.v2.summary API due to missing TensorBoard installation

@DankeGott

This comment has been minimized.

Copy link

@DankeGott DankeGott commented Feb 24, 2019

Same situation ...

@vimukthiD

This comment has been minimized.

Copy link

@vimukthiD vimukthiD commented Feb 24, 2019

Same issue ..

@geppyp

This comment has been minimized.

Copy link

@geppyp geppyp commented Feb 24, 2019

Same issue here...

@ttyen

This comment has been minimized.

Copy link

@ttyen ttyen commented Feb 24, 2019

same issue to me:
ubuntu 18.04.2 LTS
python 3.6.7
Bazel version : 0.22.0
NO GPU

@huntzhan

This comment has been minimized.

Copy link

@huntzhan huntzhan commented Feb 24, 2019

And the PyPI hasn't been updated yet.

@DankeGott

This comment has been minimized.

Copy link

@DankeGott DankeGott commented Feb 24, 2019

same issue,but my tensorboard run properly.
maybe you can try compile your code in terminal,
then try
tensorboard --logdir="./graphs" --port number(anyone you want)
and open the address you set in browser(ie.http://localhost:10086/)

@njzjz

This comment has been minimized.

Copy link

@njzjz njzjz commented Feb 24, 2019

Is it because TF_MINOR_VERSION is still 12? I have submitted #26051 to update it.

@beew

This comment has been minimized.

Copy link
Author

@beew beew commented Feb 24, 2019

You can change the version by editing tensorflow-1.13.0/tensorflow/tools/pip_package/setup.py and change line 48 to _VERSION = '1.13.0' (typo in the original?) But the tensorboard error persists.

Limited tf.compat.v2.summary API due to missing TensorBoard installation
@gunan

This comment has been minimized.

Copy link
Member

@gunan gunan commented Feb 25, 2019

Yeah, it is because you need more than renaming the file to update the version.
Did you build it from the branch r1.13?

@beew

This comment has been minimized.

Copy link
Author

@beew beew commented Feb 25, 2019

@gunan

I downloaded the 1.13 release tarball from https://github.com/tensorflow/tensorflow/releases Now 1.13 appears to have been removed from the server (unreleased?) the newest version on the link has been back to 1.13rc2 since maybe last night.

@gunan

This comment has been minimized.

Copy link
Member

@gunan gunan commented Feb 25, 2019

I made a mistake with that, and that tarball was created with the master version. 1,13,1 is being prepared which will have the correct sources.

@beew

This comment has been minimized.

Copy link
Author

@beew beew commented Feb 26, 2019

@gunan

It works now, tf 1.13.1 compiled and installed successfully. Thanks!

@beew beew closed this Feb 26, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
9 participants
You can’t perform that action at this time.