Clone or download
bflad Merge pull request #7191 from terraform-providers/td-cloudformation-0.12
service/cloudformation: Ensure parameters configurations in testing and documentation use equals
Latest commit 3f39778 Jan 17, 2019

README.md

Terraform Provider

Requirements

  • Terraform 0.10+
  • Go 1.11 (to build the provider plugin)

Building The Provider

Clone repository to: $GOPATH/src/github.com/terraform-providers/terraform-provider-aws

$ mkdir -p $GOPATH/src/github.com/terraform-providers; cd $GOPATH/src/github.com/terraform-providers
$ git clone git@github.com:terraform-providers/terraform-provider-aws

Enter the provider directory and build the provider

$ cd $GOPATH/src/github.com/terraform-providers/terraform-provider-aws
$ make build

Using the provider

If you're building the provider, follow the instructions to install it as a plugin. After placing it into your plugins directory, run terraform init to initialize it. Documentation about the provider specific configuration options can be found on the provider's website.

Developing the Provider

If you wish to work on the provider, you'll first need Go installed on your machine (version 1.11+ is required). You'll also need to correctly setup a GOPATH, as well as adding $GOPATH/bin to your $PATH.

To compile the provider, run make build. This will build the provider and put the provider binary in the $GOPATH/bin directory.

$ make build
...
$ $GOPATH/bin/terraform-provider-aws
...

In order to test the provider, you can simply run make test.

Note: Make sure no AWS_ACCESS_KEY_ID or AWS_SECRET_ACCESS_KEY variables are set, and there's no [default] section in the AWS credentials file ~/.aws/credentials.

$ make test

In order to run the full suite of Acceptance tests, run make testacc.

Note: Acceptance tests create real resources, and often cost money to run.

$ make testacc

If you need to add a new package in the vendor directory under github.com/aws/aws-sdk-go, create a separate PR handling only the update of the vendor for your new requirement. Make sure to pin your dependency to a specific version, and that all versions of github.com/aws/aws-sdk-go/* are pinned to the same version.