Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
56 lines (37 sloc) 2.49 KB
layout page_title sidebar_current description
dnsimple
Provider: DNSimple
docs-dnsimple-index
The DNSimple provider is used to interact with the resources supported by DNSimple. The provider needs to be configured with the proper credentials before it can be used.

DNSimple Provider

The DNSimple provider is used to interact with the resources supported by DNSimple. The provider needs to be configured with the proper credentials before it can be used.

Use the navigation to the left to read about the available resources.

Example Usage

# Configure the DNSimple provider
provider "dnsimple" {
  token = "${var.dnsimple_token}"
  account = "${var.dnsimple_account}"
}

# Create a record
resource "dnsimple_record" "www" {
  # ...
}

API v2 vs API v1

This integration uses the new DNSimple API v2 released on December 2016. The API v2 provides support for multi-accounts and requires a new authentication mechanism.

If you are upgrading from a previous Terraform version and you were using the API v1, you will need to upgrade the DNSimple provider configuration to use the new API access token and specify the Account ID. Terraform will automatically detect an existing legacy configurations and it will return an error message asking to upgrade.

API v1 is no longer supported. If you are using the DNSIMPLE_EMAIL argument, you can safely remove it once you have upgraded to API v2. To use API v1 you will need to use a Terraform version lower than 0.9.

To upgrade from the DNSimple provider API v1 to DNSimple provider API v2 follow these steps:

  1. Generate an API v2 access token
  2. Determine the Account ID
  3. Add the account configuration and update the token, as shown in the example above
  4. Remove the email configuration, as it's no longer used

Argument Reference

The following arguments are supported:

  • token - (Required) The DNSimple API v2 token. It must be provided, but it can also be sourced from the DNSIMPLE_TOKEN environment variable. Please note that this must be an API v2 token. You can use either an User or Account token, but an Account token is recommended.
  • account - (Required) The ID of the account associated with the token. It must be provided, but it can also be sourced from the DNSIMPLE_ACCOUNT environment variable.
You can’t perform that action at this time.