Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SSL errors return the wrong HTTP code #756

Open
HipsterBrown opened this Issue Jun 2, 2016 · 3 comments

Comments

Projects
None yet
5 participants
@HipsterBrown
Copy link
Contributor

HipsterBrown commented Jun 2, 2016

There was an issue when the SSL certificates for Tessel domains expired and created error in the CLI when folks tried to update Tessel firmware or run/push new code that used binary modules. As @reconbot explained:

we were getting the wrong error, ssl errors are not 404s and shouldn’t have the same error message

Rather than treating every failed response back from S3 as a 404, we should handle specific error codes with different error messaging.

@mittalshravika

This comment has been minimized.

Copy link

mittalshravika commented Aug 21, 2017

I was trying to work on this issue. How should I begin with for resolving this?

@rwaldron

This comment has been minimized.

@Frijol

This comment has been minimized.

Copy link
Member

Frijol commented Aug 22, 2017

@rwaldron are there docs somewhere for the dns package we use? I found https://github.com/hbouvier/dns but haven't found the lookup function that's getting called

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.