Skip to content

@release-drafter release-drafter released this Sep 26, 2019 · 82 commits to master since this release

What's Changed

🚔 Security

  • Reduce logs in EnvironmentAndSystemPropertyClientProviderStrategy (#1913) @rnorth. This fixes an issue (#1912) whereby docker registry credentials could be logged:
    • if credentials were hardcoded in ~/.docker/config.json and
    • if Testcontainers detected environment variables/system properties (such as DOCKER_HOST) which set/override the address of the docker daemon.

We recommend that you check recent CI logs for any accidentally logged credentials, and apologise for the inconvenience. Please see below for an example of the log message, which occurs during initial connection to the Docker daemon.

INFO  o.t.d.DockerClientProviderStrategy - Found Docker environment with Environment 
variables, system properties and defaults. Resolved: 
    dockerHost=unix:///var/run/docker.sock
    apiVersion='{UNKNOWN_VERSION}'
    registryUrl='https://index.docker.io/v1/'
    registryUsername='...'
    registryPassword='...'
    registryEmail='...'
    dockerConfig='DefaultDockerClientConfig[dockerHost=
unix:///var/run/docker.sock,registryUsername=...,registryPassword=<...>,
registryEmail=<...>,registryUrl=https://index.docker.io/v1/,
dockerConfigPath=/home/user/.docker,sslConfig=<null>,
apiVersion={UNKNOWN_VERSION},dockerConfig=<null>]'

has been changed to:

INFO  o.t.d.DockerClientProviderStrategy - Found Docker environment with Environment 
variables, system properties and defaults. Resolved dockerHost=unix:///var/run/docker.sock

Other changes

📖 Documentation

📦 Dependency updates

Click to expand...
  • Bump commons-dbutils from 1.6 to 1.7 in /modules/oracle-xe (#1905) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.635 to 1.11.636 in /modules/localstack (#1901) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.633 to 1.11.635 in /modules/localstack (#1896) @dependabot-preview
  • Bump tomcat-jdbc from 9.0.24 to 9.0.26 in /modules/mysql (#1894) @dependabot-preview
  • Bump HikariCP from 3.4.0 to 3.4.1 in /modules/spock (#1888) @dependabot-preview
  • Bump tomcat-jdbc from 9.0.24 to 9.0.26 in /modules/mariadb (#1895) @dependabot-preview
  • Bump HikariCP from 3.4.0 to 3.4.1 in /modules/junit-jupiter (#1889) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.632 to 1.11.633 in /modules/localstack (#1885) @dependabot-preview
  • Bump HikariCP from 3.3.1 to 3.4.0 in /modules/junit-jupiter (#1883) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.631 to 1.11.632 in /modules/localstack (#1884) @dependabot-preview
  • Bump HikariCP from 3.3.1 to 3.4.0 in /modules/spock (#1882) @dependabot-preview
  • Bump postgresql from 42.2.7 to 42.2.8 in /modules/postgresql (#1876) @dependabot-preview
  • Bump postgresql from 42.2.7 to 42.2.8 in /modules/spock (#1878) @dependabot-preview
  • Bump postgresql from 42.2.7 to 42.2.8 in /examples (#1879) @dependabot-preview
  • Bump mariadb-java-client from 2.4.3 to 2.4.4 in /modules/mariadb (#1875) @dependabot-preview
  • Bump postgresql from 42.2.7 to 42.2.8 in /modules/junit-jupiter (#1877) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.630 to 1.11.631 in /modules/localstack (#1869) @dependabot-preview
  • Bump elasticsearch-rest-client from 7.3.1 to 7.3.2 in /modules/elasticsearch (#1870) @dependabot-preview
  • Bump lombok from 1.18.8 to 1.18.10 in /examples (#1867) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.629 to 1.11.630 in /modules/localstack (#1866) @dependabot-preview
  • Bump postgresql from 42.2.6 to 42.2.7 in /modules/postgresql (#1857) @dependabot-preview
  • Bump okhttp from 3.14.2 to 3.14.3 in /examples (#1861) @dependabot-preview
  • Bump postgresql from 42.2.6 to 42.2.7 in /examples (#1862) @dependabot-preview
  • Bump postgresql from 42.2.6 to 42.2.7 in /modules/spock (#1860) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.628 to 1.11.629 in /modules/localstack (#1858) @dependabot-preview
  • Bump postgresql from 42.2.6 to 42.2.7 in /modules/junit-jupiter (#1856) @dependabot-preview
  • Bump junit-jupiter-engine from 5.5.1 to 5.5.2 in /modules/junit-jupiter (#1840) @dependabot-preview
  • Bump aws-java-sdk-sqs from 1.11.626 to 1.11.628 in /modules/localstack (#1852) @dependabot-preview
  • Bump httpclient from 4.5.9 to 4.5.10 in /modules/junit-jupiter (#1851) @dependabot-preview
  • Bump junit-jupiter-api from 5.5.1 to 5.5.2 in /modules/junit-jupiter (#1842) @dependabot-preview
  • Bump httpclient from 4.5.9 to 4.5.10 in /modules/spock (#1850) @dependabot-preview
  • Bump rest-assured from 4.1.0 to 4.1.1 in /modules/vault (#1839) @dependabot-preview
  • Bump testng from 6.14.3 to 7.0.0 in /examples (#1756) @dependabot-preview
Assets 2
You can’t perform that action at this time.