Solution for libusb not installed (Ubuntu) #123

Closed
erkserkserks opened this Issue Jan 17, 2013 · 2 comments

Projects

None yet

3 participants

@erkserkserks

If you are getting "configure: error: *** Required libusb-1.0 >= 1.0.0 not installed ***" on Ubuntu, then you probably need to install libusb-1.0-0-dev. Stlink does not use libusb-dev. To install the correct version, type "sudo apt-get install libusb-1.0-0-dev"

@QianFan-Zhao

Hello,In my Ubuntu14.04,I try ./configure.but check usb has error:like this:
configure: error: *** Required libusb-1.0 >= 1.0.0 not installed ***

but when i tty to "sudo apt-get install libusb-1.0-0-dev":
The following packages have unmet dependencies:
libusb-1.0-0-dev : Depends: libusb-1.0-0 (= 2:1.0.6-1) but 2:1.0.17-1ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

How can i do to resolve this ?
Thanks

@xor-gate xor-gate closed this May 17, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment