Permalink
Browse files

Point Gemfle at gemspec. Add rake dependency.

You can tell your Gemfile to just look at the gemspec to figure out what
to bundle up. Also, rake seemed like a development dependency, since it
was being required.
  • Loading branch information...
1 parent 339381c commit 262e20d241fd041e55a2d1281b1b453bbbc56a16 @benhamill benhamill committed Sep 9, 2011
Showing with 4 additions and 6 deletions.
  1. +1 −6 Gemfile
  2. +3 −0 texticle.gemspec
View
@@ -1,8 +1,3 @@
source 'https://rubygems.org'
-gem 'activerecord'
-
-group :test, :development do
- gem 'pg'
- gem 'shoulda'
-end
+gemspec
View
@@ -28,16 +28,19 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<pg>, [">= 0.11.0"])
s.add_development_dependency(%q<shoulda>, [">= 2.11.3"])
+ s.add_development_dependency(%q<rake>, [">= 0.8.0"])
s.add_dependency(%q<activerecord>, [">= 3.0.0"])
else
s.add_dependency(%q<pg>, [">= 0.11.0"])
s.add_dependency(%q<shoulda>, [">= 2.11.3"])
+ s.add_dependency(%q<rake>, [">= 0.8.0"])
s.add_dependency(%q<activerecord>, [">= 3.0.0"])
end
else
s.add_dependency(%q<pg>, [">= 0.11.0"])
s.add_dependency(%q<shoulda>, [">= 2.11.3"])
+ s.add_dependency(%q<rake>, [">= 0.8.0"])
s.add_dependency(%q<activerecord>, [">= 3.0.0"])
end
end

0 comments on commit 262e20d

Please sign in to comment.