Permalink
Browse files

Only require version in gemspec

Using texticle master in a Gemfile using git fails due to failure to require active_record, which is required by the top level texticle.rb, loaded by the gemspec, which only actually requires the version.
  • Loading branch information...
1 parent 301c2e7 commit fe41748c772d43120e5580acc8e02acc6998a6f8 @sj26 sj26 committed Oct 13, 2012
Showing with 7 additions and 4 deletions.
  1. +2 −2 lib/texticle.rb
  2. +3 −0 lib/texticle/version.rb
  3. +2 −2 texticle.gemspec
View
@@ -1,8 +1,8 @@
require 'active_record'
-module Texticle
- VERSION = '2.0.3'
+require 'texticle/version'
+module Texticle
def self.version
VERSION
end
View
@@ -0,0 +1,3 @@
+module Texticle
+ VERSION = '2.0.3'
+end
View
@@ -1,10 +1,10 @@
# -*- encoding: utf-8 -*-
-require File.expand_path('../lib/texticle', __FILE__)
+require File.expand_path('../lib/texticle/version', __FILE__)
Gem::Specification.new do |s|
s.name = 'texticle'
- s.version = Texticle.version
+ s.version = Texticle::VERSION
s.summary = 'Texticle exposes full text search capabilities from PostgreSQL'
s.description = 'Texticle exposes full text search capabilities from PostgreSQL, extending

0 comments on commit fe41748

Please sign in to comment.