Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Commits on Feb 11, 2015
  1. @infininight
Commits on Nov 1, 2014
  1. @infininight

    Support :true/:false for disabled key

    infininight authored
    Also update snippet to use :true
Commits on Sep 13, 2014
  1. @infininight
Commits on Sep 9, 2014
  1. @infininight

    Add grammar for individual scopes

    infininight authored
    To be expanded in the future to support scope selectors.
Commits on Jul 31, 2014
  1. @sorbits

    Do not require rubygems (not available via ruby 1.8 on Yosemite)

    sorbits authored
    I also removed the other unused (and commented) includes.
Commits on Jun 18, 2014
  1. @infininight

    Point to ruby 1.8 shim

    infininight authored
    Using a shim allows us to catch when 1.8 of ruby is not present and provide other options.
    
    #ignore
Commits on May 5, 2014
  1. @savetheclocktower

    Fix "Show Scope" command to include the left scope

    savetheclocktower authored
    The left-hand scope is represented by the `TM_SCOPE_LEFT` environment variable, not `TM_LEFT_SCOPE`, meaning that the left scope never actually showed up.
Commits on Apr 29, 2014
  1. @sorbits
  2. @sorbits

    Revise bundle development bundle

    sorbits authored
    Made the Require Support File (sup⇥) and TextMate Variable (env⇥) snippets use pop-up menus.
    
    Removed “Show Changes” which was for subversion.
Commits on Mar 13, 2014
  1. @sorbits

    Overload rb⇥ in the bundle editor to insert ruby 1.8 shebang

    sorbits authored
    This requires TextMate 2.0-alpha.9521 for the new bundle editor scope.
  2. @infininight
Commits on Nov 1, 2013
  1. @infininight
Commits on Sep 26, 2013
  1. @infininight
Commits on Aug 29, 2013
  1. @infininight
Commits on Jul 27, 2013
  1. @infininight

    Use version 1.8 of ruby for bundle items

    infininight authored
    10.7 and 10.8 only include ruby 1.8, so all bundle items have been written to work with that. Optionally supporting ruby 1.9 and 2.0 is problematic as these versions are not fully backwards compatible.
    
    #ignore
Commits on Mar 13, 2013
  1. @sorbits
Commits on Sep 25, 2012
  1. @infininight

    Remove usage of main preference file for theme settings.

    infininight authored
    Instead use TM_CURRENT_THEME_PATH and the TM_QUERY tool.
Commits on Sep 19, 2012
  1. @infininight
Commits on Sep 15, 2012
  1. @infininight
Commits on Jan 21, 2012
  1. Fix Show Source (HTML) to work when a non-default theme is selected

    Brandon Fryslie authored
    Changed Show Source (HTML) to try using the Twilight theme before failing completely if it can't find your current theme.
    
    Signed-off-by: Brandon Fryslie <sssssmokey@gmail.com>
Commits on Dec 21, 2011
  1. @infininight
Commits on Dec 9, 2011
  1. @infininight
Commits on Dec 2, 2011
  1. @infininight
Commits on Nov 28, 2011
  1. @infininight

    Allow comments.

    infininight authored
  2. @infininight
Commits on Nov 26, 2011
  1. @infininight
  2. @infininight
Commits on Nov 12, 2011
  1. @infininight

    Move folding settings.

    infininight authored
  2. @infininight

    Add readme.

    infininight authored
  3. @infininight
  4. @infininight
Commits on Sep 9, 2011
  1. @infininight
Commits on Sep 8, 2011
  1. @infininight

    Support injection rules.

    infininight authored
  2. @infininight
Commits on Aug 30, 2011
  1. @infininight
Something went wrong with that request. Please try again.