Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Remove usage of TM_RUBY.

  • Loading branch information...
commit 0a9987b37fe6fc26d43c63a3e83fef735822d567 1 parent efc4e36
@infininight infininight authored
View
2  Commands/Add to Repository.plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" -r "$TM_SUPPORT_PATH/lib/shelltokenize.rb" &lt;&lt;END
+ruby -r "$TM_SUPPORT_PATH/lib/shelltokenize.rb" &lt;&lt;END
cvs = ENV['TM_CVS'] || "cvs"
TextMate.selected_paths_array.each do |path|
puts %x{cd "#{File.dirname path}" &amp;&amp; #{cvs} add "#{File.basename path}"}
View
2  Commands/Annotate Line.plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Check out Revision....plist
@@ -36,7 +36,7 @@ if [[ $revs = "false" ]]; then
fi
export REVS="$revs"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Commit....plist
@@ -11,7 +11,7 @@ export TM_CVS
export CommitWindow="$TM_SUPPORT_PATH/bin/CommitWindow.app/Contents/MacOS/CommitWindow"
cd "${TM_PROJECT_DIRECTORY:-$TM_DIRECTORY}"
-"${TM_RUBY:-ruby}" -- "${TM_BUNDLE_SUPPORT}/cvs_commit.rb"</string>
+ruby -- "${TM_BUNDLE_SUPPORT}/cvs_commit.rb"</string>
<key>input</key>
<string>none</string>
<key>keyEquivalent</key>
View
2  Commands/Diff With Newest (HEAD).plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Diff With Previous Revision (PREV).plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Diff With Revision....plist
@@ -36,7 +36,7 @@ if [[ $revs = "false" ]]; then
fi
export REVS="$revs"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Diff With Working Copy (BASE).plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Merge from tag....plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Reset sticky tags.plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
View
2  Commands/Update with tag....plist
@@ -7,7 +7,7 @@
<key>command</key>
<string>require_cmd "${TM_CVS:=cvs}" "If you have installed cvs, then you need to either update your &lt;tt&gt;PATH&lt;/tt&gt; or set the &lt;tt&gt;TM_CVS&lt;/tt&gt; shell variable (e.g. in Preferences / Advanced)"
-"${TM_RUBY:-ruby}" &lt;&lt;'END'
+ruby &lt;&lt;'END'
ENV['CVS_PATH'] = ENV['TM_CVS']
$LOAD_PATH &lt;&lt; ENV['TM_BUNDLE_SUPPORT']
Please sign in to comment.
Something went wrong with that request. Please try again.