Permalink
Browse files

Use version 1.8 of ruby for bundle items

10.7 and 10.8 only include ruby 1.8, so all bundle items have been written to work with that. Optionally supporting ruby 1.9 and 2.0 is problematic as these versions are not fully backwards compatible.

#ignore
  • Loading branch information...
1 parent fbd3443 commit c59784a746ef193181dbcd8766f93729b87982dc @infininight infininight committed Jul 27, 2013
Showing with 4 additions and 4 deletions.
  1. +1 −1 Commands/Add to repository.plist
  2. +1 −1 Commands/Changes.plist
  3. +1 −1 Commands/Record All.plist
  4. +1 −1 Commands/Record.plist
@@ -14,7 +14,7 @@ else
fi
export DARCSPaths
-ruby <<'EOF'
+/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby <<'EOF'
require 'pathname'
basedir = Pathname.new(ENV['TM_DIRECTORY']).realpath()
View
@@ -7,7 +7,7 @@
<key>command</key>
<string>cd "${TM_PROJECT_DIRECTORY:=$TM_DIRECTORY}";
-ruby &lt;&lt;'EOF'
+/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby &lt;&lt;'EOF'
require 'rexml/document'
require 'time'
@@ -7,7 +7,7 @@
<key>command</key>
<string>cd "${TM_PROJECT_DIRECTORY:=$TM_DIRECTORY}";
-ruby &lt;&lt;'RUBY'
+/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby &lt;&lt;'RUBY'
require "#{ENV['TM_SUPPORT_PATH']}/lib/exit_codes.rb"
require "#{ENV['TM_SUPPORT_PATH']}/lib/ui.rb"
View
@@ -7,7 +7,7 @@
<key>command</key>
<string>cd "$TM_DIRECTORY";
-ruby &lt;&lt;'RUBY'
+/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby &lt;&lt;'RUBY'
require "#{ENV['TM_SUPPORT_PATH']}/lib/exit_codes.rb"
require "#{ENV['TM_SUPPORT_PATH']}/lib/ui.rb"

0 comments on commit c59784a

Please sign in to comment.