Browse files

Use version 1.8 of ruby for bundle items

10.7 and 10.8 only include ruby 1.8, so all bundle items have been written to work with that. Optionally supporting ruby 1.9 and 2.0 is problematic as these versions are not fully backwards compatible.

#ignore
  • Loading branch information...
1 parent c2a675a commit 872b8b47ebe970b64174b44a0bbbb2bce4d394c7 @infininight infininight committed Dec 27, 2013
Showing with 2 additions and 2 deletions.
  1. +2 −2 Support/resource/rb_gateway.js
View
4 Support/resource/rb_gateway.js
@@ -17,7 +17,7 @@ function gateway_command(command, params) {
// var cmd = arguments.shift
// var params = arguments
try {
- command = "ruby " + e_sh(TM_BUNDLE_SUPPORT) + "/gateway/" + command
+ command = "/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby " + e_sh(TM_BUNDLE_SUPPORT) + "/gateway/" + command
return exec(command, params).outputString
}
catch(err) {
@@ -29,7 +29,7 @@ function gateway_command(command, params) {
function dispatch(params) {
try {
params = $H(params).map(function(pair) { return(pair.key + "=" + pair.value.toString())})
- command = "ruby " + e_sh(TM_BUNDLE_SUPPORT) + "/dispatch.rb";
+ command = "/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby " + e_sh(TM_BUNDLE_SUPPORT) + "/dispatch.rb";
// return params.map(function(a) { return e_sh(a) }).join(" ")
return exec(command, params).outputString
}

0 comments on commit 872b8b4

Please sign in to comment.