Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

TextMate support for Groovy

branch: master

Use version 1.8 of ruby for bundle items

10.7 and 10.8 only include ruby 1.8, so all bundle items have been written to work with that. Optionally supporting ruby 1.9 and 2.0 is problematic as these versions are not fully backwards compatible.

#ignore
latest commit 31e26668f0
Michael Sheets infininight authored
Octocat-spinner-32 Commands Use version 1.8 of ruby for bundle items July 27, 2013
Octocat-spinner-32 Preferences Match variables anywhere, not just in classes. July 05, 2009
Octocat-spinner-32 Snippets Removed some snippets that are now in the java bundle. March 22, 2011
Octocat-spinner-32 Support Use version 1.8 of ruby for bundle items July 27, 2013
Octocat-spinner-32 Syntaxes Allow tag closure to end import rules, fixes #7. October 05, 2012
Octocat-spinner-32 README.mdown added readme with installation instructions June 17, 2011
Octocat-spinner-32 info.plist Added generate package command from Java bundle. June 04, 2011
README.mdown

Installation

Without git

See Groovy site installation instructions

With git

With git installed, you can checkout the bundle from github.

cd into bundle dir and clone the bundle:

cd ~/Library/Application\ Support/TextMate/Bundles/
git clone https://github.com/textmate/groovy.tmbundle.git

Now restart TextMate or tell it to reload bundles.

osascript -e 'tell app "TextMate" to reload bundles'

Now you're ready to go.

To update your groovy bundle, cd into the groovy bundle dir and run git pull origin master

Something went wrong with that request. Please try again.