Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Use version 1.8 of ruby for bundle items

10.7 and 10.8 only include ruby 1.8, so all bundle items have been written to work with that. Optionally supporting ruby 1.9 and 2.0 is problematic as these versions are not fully backwards compatible.

#ignore
  • Loading branch information...
commit 77c4e1809f1fb88142fe02fb726511043566bad6 1 parent a011c1f
Michael Sheets infininight authored
Showing with 1 addition and 1 deletion.
  1. +1 −1  Commands/Reformat Comment.tmCommand
2  Commands/Reformat Comment.tmCommand
View
@@ -22,7 +22,7 @@ flags = %Q{-p "#{cstring}"}
flags += " --retabify" unless ENV["TM_SOFT_TABS"] == "YES"
flags += " -c #{ENV['TM_COLUMNS'].nil? ? 80 : ENV['TM_COLUMNS']}"
-command = "ruby #{e_sh(ENV["TM_BUNDLE_SUPPORT"])}/bin/rubywrap.rb #{flags}"
+command = "/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby #{e_sh(ENV["TM_BUNDLE_SUPPORT"])}/bin/rubywrap.rb #{flags}"
text = open("| #{command}", "r+") do |wrapper|
wrapper << ctext
wrapper.close_write
Please sign in to comment.
Something went wrong with that request. Please try again.