Browse files

Use version 1.8 of ruby for bundle items

10.7 and 10.8 only include ruby 1.8, so all bundle items have been written to work with that. Optionally supporting ruby 1.9 and 2.0 is problematic as these versions are not fully backwards compatible.

#ignore
  • Loading branch information...
1 parent 20e8f18 commit c1b4d87f1dccd936ff1663b6e089b2140bbfc409 @infininight infininight committed Dec 27, 2013
Showing with 2 additions and 2 deletions.
  1. +1 −1 Commands/Tidy XML.plist
  2. +1 −1 Preferences/Comments.plist
View
2 Commands/Tidy XML.plist
@@ -6,7 +6,7 @@
<string>nop</string>
<key>command</key>
<string>if [[ "$TM_SOFT_TABS" = "YES" ]];
- then export XMLLINT_INDENT=`ruby -e"print(' ' * ${TM_TAB_SIZE})"`
+ then export XMLLINT_INDENT=`/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby -e"print(' ' * ${TM_TAB_SIZE})"`
else export XMLLINT_INDENT=$'\t'
fi
result=`xmllint --format - 2&gt;&amp;1`
View
2 Preferences/Comments.plist
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
+<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>name</key>

0 comments on commit c1b4d87

Please sign in to comment.