Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add support for PHP 5.3 #20

Closed
richtabor opened this Issue Mar 4, 2019 · 0 comments

Comments

1 participant
@richtabor
Copy link
Member

richtabor commented Mar 4, 2019

As requested via this WP.org ticket.

The description of this plug-in says that the required PHP version is 5.2.4 or higher. However upon trying to activate the plug-in on top of PHP 5.3.x, the following error shows up:

Parse error: syntax error, unexpected '[' in /var/www/my_wp_path/wp-content/plugins/block-gallery/includes/admin/class-block-gallery-action-links.php on line 87.

This particular error is due to the used array initialization which was introduced in PHP 5.4.x.

Would be great to have the plug-in working on top of 5.3.x, or even 5.2.4 as mentioned in the requirements.

richtabor added a commit that referenced this issue Mar 4, 2019

@richtabor richtabor closed this Mar 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.