Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CVE-2018-16301 information #855

Open
Beuc opened this issue Oct 4, 2019 · 4 comments

Comments

@Beuc
Copy link

@Beuc Beuc commented Oct 4, 2019

Hi,

I'm part of the Debian Long Term Support team, and I'd like to assess if our packaged versions of libpcap are affected by CVE-2018-16301.

81c4e00 says it relates to "errors in pcapng reading", but I cannot identify the related commit.

In addition,
https://www.tcpdump.org/public-cve-list.txt
doesn't list it as fixed, and marks it as affecting tcpdump rather than libpcap.

Can you link the specific fix?
Regards,

@mcr

This comment has been minimized.

Copy link
Member

@mcr mcr commented Oct 6, 2019

@Beuc

This comment has been minimized.

Copy link
Author

@Beuc Beuc commented Oct 6, 2019

Thanks @mcr.

@carnil

This comment has been minimized.

Copy link

@carnil carnil commented Oct 6, 2019

@mcr

This comment has been minimized.

Copy link
Member

@mcr mcr commented Oct 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
3 participants
You can’t perform that action at this time.