New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[ssr script] Not working on Ubuntu 17.1, please advise how to fix this #3

Closed
OutGazing opened this Issue Nov 21, 2017 · 4 comments

Comments

2 participants
@OutGazing

OutGazing commented Nov 21, 2017

here below is the output after inputting "ssr start" with super user privilege [the proxy info in the configure file("~/.local/share/shadowsocksr/config.json") is correct and effective for sure] :

2017-11-21 19:04:53 INFO     util.py:85 loading libsodium from libsodium.so.18
started
Testing Connection...
curl: (52) Empty reply from server


@OutGazing OutGazing changed the title from Not working in Ubuntu 17.1, please advise how to fix this to Not working on Ubuntu 17.1, please advise how to fix this Nov 21, 2017

@the0demiurge

This comment has been minimized.

Owner

the0demiurge commented Nov 21, 2017

It seems there are some issues in your config file, try ssr config and check or edit your configuration:)

Or you may try config files from ss.pythonic.life/json

@OutGazing

This comment has been minimized.

OutGazing commented Nov 22, 2017

Thanks for your reply, but it still failed to take effect.
I reinstalled it, input "ssr update" into the terminal, and the output is as follows:~# ssr update % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 68 100 68 0 0 68 0 0:00:01 --:--:-- 0:00:01 71 curl: (7) Failed to connect to gentle-oasis-59484.herokuapp.com port 443: Connection refused

@the0demiurge

This comment has been minimized.

Owner

the0demiurge commented Nov 23, 2017

The webpage was blocked, and you can edit the $WEBSITE in ssr script to a new url.

For more information, see ShadowsocksShare-OpenShift#17

@the0demiurge the0demiurge changed the title from Not working on Ubuntu 17.1, please advise how to fix this to [ssr script] Not working on Ubuntu 17.1, please advise how to fix this Nov 23, 2017

@OutGazing

This comment has been minimized.

OutGazing commented Nov 23, 2017

It turned out to be something wrong with the format of the config JSON file. All set, good to go. Thanks for your patience and reply, though.

@OutGazing OutGazing closed this Nov 23, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment