Use module_cache method instead of @module_cache #44

Merged
merged 1 commit into from May 24, 2013

Conversation

Projects
None yet
2 participants
@korny

korny commented Apr 3, 2013

This fixes a crash that I get on our app (@module_cache is nil). I can't really tell you why, but I wanted to share our "hotfix" in case it's really a bug.

@thedarkone

This comment has been minimized.

Show comment Hide comment
@thedarkone

thedarkone May 24, 2013

Owner

@korny if you ever get the time, would be nice if you could run your app without this fix under the debug mode (more info in the README) and provide me with the log output, so I could figure out what goes wrong.

Sorry for taking so long to respond.

Owner

thedarkone commented May 24, 2013

@korny if you ever get the time, would be nice if you could run your app without this fix under the debug mode (more info in the README) and provide me with the log output, so I could figure out what goes wrong.

Sorry for taking so long to respond.

thedarkone added a commit that referenced this pull request May 24, 2013

Merge pull request #44 from sofatutor/fix-undefined-method-remove_const
Use module_cache method instead of @module_cache

@thedarkone thedarkone merged commit 5d4d34a into thedarkone:master May 24, 2013

@thedarkone

This comment has been minimized.

Show comment Hide comment
@thedarkone

thedarkone Aug 31, 2013

Owner

@korny I have a new branch of rails-dev-boost/mark-then-sweep-rework in the works, it reverts your (@module_cache is nil) hotfix, can you please give it a try?

gem 'rails-dev-boost', :git => 'git://github.com/thedarkone/rails-dev-boost.git', :branch => 'mark-then-sweep-rework'
Owner

thedarkone commented Aug 31, 2013

@korny I have a new branch of rails-dev-boost/mark-then-sweep-rework in the works, it reverts your (@module_cache is nil) hotfix, can you please give it a try?

gem 'rails-dev-boost', :git => 'git://github.com/thedarkone/rails-dev-boost.git', :branch => 'mark-then-sweep-rework'
@korny

This comment has been minimized.

Show comment Hide comment
@korny

korny Aug 31, 2013

Ah, damn. We already moved to Rails 3.2 and don't use rails-dev-boost anymore. So, I can't really replicate the error, since the code changed a lot.

For some reason, I didn't see your comment 3 months ago :-/ Sorry! But I guess either somebody else can reproduce the issue, or it was very specific to our app.

korny commented Aug 31, 2013

Ah, damn. We already moved to Rails 3.2 and don't use rails-dev-boost anymore. So, I can't really replicate the error, since the code changed a lot.

For some reason, I didn't see your comment 3 months ago :-/ Sorry! But I guess either somebody else can reproduce the issue, or it was very specific to our app.

@thedarkone

This comment has been minimized.

Show comment Hide comment
@thedarkone

thedarkone Aug 31, 2013

Owner

@korny alright, thanks anyway!

Owner

thedarkone commented Aug 31, 2013

@korny alright, thanks anyway!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment