Coundn't install #201

Closed
tvamsisai opened this Issue Jan 7, 2013 · 3 comments

Comments

Projects
None yet
4 participants

i got this on typing ~/subway$ npm install

npm http GET https://registry.npmjs.org/connect-assets
npm http GET https://registry.npmjs.org/iconv
npm http GET https://registry.npmjs.org/bcrypt
npm http GET https://registry.npmjs.org/express
npm http GET https://registry.npmjs.org/socket.io
npm http GET https://registry.npmjs.org/jade
npm http GET https://registry.npmjs.org/mongoose
npm http 304 https://registry.npmjs.org/connect-assets

npm ERR! Error: No compatible version found: connect-assets@'>=2.3.0- <2.4.0-'
npm ERR! Valid install targets:
npm ERR! ["1.0.0-beta1","1.0.0-beta2","1.0.0-beta3","1.0.0-beta4","1.0.0-beta5","1.0.0-beta6","1.0.0","2.0.0-alpha1","2.0.0-alpha2","2.0.0-alpha3","2.0.0-beta1","2.0.0-beta2","2.0.0-beta3","2.0.0-beta4","2.0.0-beta5","2.0.0-rc1","2.0.0","2.0.1","2.0.2","2.1.0","2.1.1","2.1.2","2.1.3","2.1.4","2.1.5","2.1.6","2.1.7","2.1.8","2.1.9","2.2.0","2.2.1"]
npm ERR! at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
npm ERR! at next_ (/usr/share/npm/lib/cache.js:438:17)
npm ERR! at next (/usr/share/npm/lib/cache.js:415:44)
npm ERR! at /usr/share/npm/lib/cache.js:408:5
npm ERR! at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
npm ERR! at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR! http://bugs.debian.org/npm
npm ERR! or use
npm ERR! reportbug --attach /home/vamsi/subway/npm-debug.log npm
npm ERR!
npm ERR! System Linux 3.5.0-21-generic
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! cwd /home/vamsi/subway
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! message No compatible version found: connect-assets@'>=2.3.0- <2.4.0-'
npm ERR! message Valid install targets:
npm ERR! message ["1.0.0-beta1","1.0.0-beta2","1.0.0-beta3","1.0.0-beta4","1.0.0-beta5","1.0.0-beta6","1.0.0","2.0.0-alpha1","2.0.0-alpha2","2.0.0-alpha3","2.0.0-beta1","2.0.0-beta2","2.0.0-beta3","2.0.0-beta4","2.0.0-beta5","2.0.0-rc1","2.0.0","2.0.1","2.0.2","2.1.0","2.1.1","2.1.2","2.1.3","2.1.4","2.1.5","2.1.6","2.1.7","2.1.8","2.1.9","2.2.0","2.2.1"]
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/vamsi/subway/npm-debug.log
npm not ok

i understand that i have the wrong version of npm installed... but every time i update using curl and npm update npm -g command i install 1.1.4 only.

how do i overcome this problem?

Owner

thedjpetersen commented Jan 15, 2013

I am running into this same problem - I will change the package.json to reference connect-assets github repo

kennu commented Feb 1, 2013

You should probably upgrade to Node 0.8 to avoid this problem.

this fixed npm install for me on ubuntu server 12.04.2;

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:chris-lea/node.js
sudo apt-get update
sudo apt-get install nodejs npm
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment