Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

errrors during install #267

Closed
Code-nomad opened this Issue Aug 13, 2013 · 5 comments

Comments

Projects
None yet
2 participants

I tried to install the server but it comes up on an error when i try. I pasted the log here. Advice anyone?

9592 error Error: ENOENT, lstat '/root/tmp/npm-640-5wlDCzqv/1376437284546-0.4601695721503347/package/.npmignore'
9593 error If you need help, you may report this log at:
9593 error http://github.com/isaacs/npm/issues
9593 error or email it to:
9593 error npm-@googlegroups.com
9594 error System Linux 3.1.2-vs2.3.2.1.build1-cti
9595 error command "/usr/local/bin/node" "/usr/local/bin/npm" "install"
9596 error cwd /root/subway
9597 error node -v v0.11.6-pre
9598 error npm -v 1.3.6
9599 error path /root/tmp/npm-640-5wlDCzqv/1376437284546-0.4601695721503347/package/.npmignore
9600 error fstream_path /root/tmp/npm-640-5wlDCzqv/1376437284546-0.4601695721503347/package/.npmignore
9601 error fstream_type File
9602 error fstream_class FileWriter
9603 error code ENOENT
9604 error errno -2
9605 error fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
9605 error fstream_stack Object.oncomplete (fs.js:96:15)
9606 verbose exit [ -2, true ]

Collaborator

badosu commented Aug 14, 2013

@lukske123 are you running as root?

Is this the output of npm install?

i am installing it as root and this is the result of npm install after
following all instructions. I am on debian 6.0 minimal on a vps.

2013/8/14 Amadeus Folego notifications@github.com

@lukske123 https://github.com/lukske123 are you running as root?

Is this the output of npm install?


Reply to this email directly or view it on GitHubhttps://github.com/thedjpetersen/subway/issues/267#issuecomment-22640242
.

Beste

Met vriendelijke groeten

Lucas Van Beneden

i reinstalled the OS just to be sure and managed to capture the commandline output this time: here goes:

sqlite3@2.1.15 install /opt/subway/node_modules/jugglingdb-sqlite3/node_modules/sqlite3
node-gyp rebuild

npm http 200 https://registry.npmjs.org/uglify-js/1.2.5
npm http GET https://registry.npmjs.org/uglify-js/-/uglify-js-1.2.5.tgz
npm http 200 https://registry.npmjs.org/active-x-obfuscator/0.0.1
npm http GET https://registry.npmjs.org/active-x-obfuscator/-/active-x-obfuscator-0.0.1.tgz
gyp ERR! configure error
gyp ERR! stack Error: "pre" versions of node cannot be installed, use the --nodedir flag instead
gyp ERR! stack at install (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/install.js:65:16)
gyp ERR! stack at Object.self.commands.(anonymous function) as install
gyp ERR! stack at getNodeDir (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:228:20)
gyp ERR! stack at /usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:110:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:640:7)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:103:17)
gyp ERR! stack at maybeClose (child_process.js:740:16)
gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:807:5)
gyp ERR! System Linux 3.1.2-vs2.3.2.1.build1-cti
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/subway/node_modules/jugglingdb-sqlite3/node_modules/sqlite3
gyp ERR! node -v v0.11.6-pre
gyp ERR! node-gyp -v v0.10.6
gyp ERR! not ok
npm ERR! weird error 1
npm http 200 https://registry.npmjs.org/xmlhttprequest/1.4.2
npm http 200 https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.2.tgz
npm http GET https://registry.npmjs.org/xmlhttprequest/-/xmlhttprequest-1.4.2.tgz
npm http 200 https://registry.npmjs.org/amdefine/-/amdefine-0.0.8.tgz
npm http 200 https://registry.npmjs.org/minimatch/-/minimatch-0.2.12.tgz
npm http 200 https://registry.npmjs.org/ws
npm http GET https://registry.npmjs.org/ws/-/ws-0.4.27.tgz
npm http 200 https://registry.npmjs.org/active-x-obfuscator/-/active-x-obfuscator-0.0.1.tgz
npm http 200 https://registry.npmjs.org/uglify-js/-/uglify-js-1.2.5.tgz
npm http 200 https://registry.npmjs.org/xmlhttprequest/-/xmlhttprequest-1.4.2.tgz
npm http 200 https://registry.npmjs.org/ws/-/ws-0.4.27.tgz
npm ERR! not ok code 0

update: installing npm and nodejs from checkinstall produced deb did the trick. Running it now. Runs like a charm 👍 kudos to all participators in this project!

Collaborator

badosu commented Aug 14, 2013

@lukske123 Nice!

So this issue is not related to subway, right?

Can you close it?

@Code-nomad Code-nomad closed this Aug 14, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment