Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

refs #19478 - update wrong webpack-dev-server dependency. #4621

Merged
merged 1 commit into from Jun 26, 2017

Conversation

Projects
None yet
4 participants
@ohadlevy
Copy link
Member

commented Jun 26, 2017

Also, update sass-loader to avoid an npm warning.
(warning "sass-loader@4.1.1" has incorrect peer dependency "webpack@^2 || ^2.2.0-rc.0 || ^2.1.0-beta || ^1.12.6".
)

@mention-bot

This comment has been minimized.

Copy link

commented Jun 26, 2017

@ohadlevy, thanks for your PR! By analyzing the history of the files in this pull request, we identified @domcleal, @tbrisker and @dLobatog to be potential reviewers.

@ohadlevy ohadlevy force-pushed the ohadlevy:19478 branch from 3f1ea7a to 17c6b75 Jun 26, 2017

@ohadlevy ohadlevy changed the title refs ##19478 - update wrong webpack-dev-server dependency. refs #19478 - update wrong webpack-dev-server dependency. Jun 26, 2017

@theforeman theforeman deleted a comment from theforeman-bot Jun 26, 2017

refs #19478 - update wrong webpack-dev-server dependency
Also, update sass-loader to avoid an npm warning:

```
warning "sass-loader@4.1.1" has incorrect peer dependency
"webpack@^2 || ^2.2.0-rc.0 || ^2.1.0-beta || ^1.12.6".
```
@ohadlevy

This comment has been minimized.

Copy link
Member Author

commented Jun 26, 2017

@tbrisker I'll appreciate the quick review. /cc @matanwerbner

@tbrisker

This comment has been minimized.

Copy link
Member

commented Jun 26, 2017

I'm seeing the following in the logs:

npm WARN extract-text-webpack-plugin@2.1.2 requires a peer of webpack@^2.2.0 but none was installed.
npm WARN babel-loader@6.2.10 requires a peer of webpack@1 || 2 || ^2.1.0-beta || ^2.2.0-rc but none was installed.
npm WARN stats-webpack-plugin@0.6.1 requires a peer of webpack@^1.0||^2.1.0-beta||^2.2.0-rc but none was installed.
npm WARN webpack-dev-server@2.5.0 requires a peer of webpack@^2.2.0 but none was installed.

Are these deps still not compatible with webpack 3 or just have wrong peer deps?
If the first we may need to downgrade webpack to 2 until they are compatible. if it's just a wrong message and there are still no correct versions please open an issue to fix these as well.

@ohadlevy

This comment has been minimized.

Copy link
Member Author

commented Jun 26, 2017

npm WARN extract-text-webpack-plugin@2.1.2 requires a peer of webpack@^2.2.0 but none was installed.

no new version was released, but it is compatible.

npm WARN babel-loader@6.2.10 requires a peer of webpack@1 || 2 || ^2.1.0-beta || ^2.2.0-rc but none was installed.

This warning exists before

npm WARN stats-webpack-plugin@0.6.1 requires a peer of webpack@^1.0||^2.1.0-beta||^2.2.0-rc but none was installed.

no new version was released, but it is compatible.

npm WARN webpack-dev-server@2.5.0 requires a peer of webpack@^2.2.0 but none was installed.

no new version was released, but it is compatible.

@tbrisker

This comment has been minimized.

Copy link
Member

commented Jun 26, 2017

Alright, I'll merge this now, please be sure to update all of these once a new version is released that removes the warnings.

@tbrisker tbrisker merged commit fa850a5 into theforeman:develop Jun 26, 2017

6 checks passed

codeclimate no new or fixed issues
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
foreman Build finished.
Details
hound No violations found. Woof!
katello Build finished.
Details
upgrade Build finished.
Details
@tbrisker

This comment has been minimized.

Copy link
Member

commented Jun 26, 2017

Thanks @ohadlevy !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.