Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Settings tab not shown in Foreman 1.18 #27

Closed
dgoetz opened this Issue Jul 6, 2018 · 7 comments

Comments

Projects
None yet
2 participants
@dgoetz
Copy link
Member

commented Jul 6, 2018

The settings tab is not shown in Foreman 1.18, but the log is showing no failure.
Only thing relevant to expire hosts is Deface: [WARNING] No :original defined for 'host_form_expired_on_field', you should change its definition to include:

@timogoebel timogoebel self-assigned this Jul 6, 2018

@timogoebel timogoebel added the bug label Jul 6, 2018

@timogoebel

This comment has been minimized.

Copy link
Member

commented Jul 6, 2018

@dgoetz: Thanks for the bug report. I'm not sure what you think is missing:

The host form is correctly enhanced:

image

I can also see the tab Expire Hosts in Settings (at least in my devel environment).

image

@dgoetz

This comment has been minimized.

Copy link
Member Author

commented Jul 6, 2018

I am missing the settings tab in 1.18.0-RC3. Can this be a collision with another plugin?

grafik
grafik

@dgoetz

This comment has been minimized.

Copy link
Member Author

commented Jul 6, 2018

It has to be a collision or caused by the number of installed plugin, because the same has now also happened with the Monitoring plugin. It is showing up as installed, in the host edit form I can set the Monitoring Smart Proxy, but no Settings tab.

@timogoebel

This comment has been minimized.

Copy link
Member

commented Jul 6, 2018

That's weird. Do the settings show up in the database (settings table)? The category should be Settings::ExpireHosts or Settings::Monitoring.

@dgoetz

This comment has been minimized.

Copy link
Member Author

commented Jul 6, 2018

No database entries are there for Settings::ExpireHosts or Setting::ExpireHosts (or Monitoring).

@timogoebel

This comment has been minimized.

Copy link
Member

commented Jul 6, 2018

That's odd, they should be loaded during app startup.

@dgoetz

This comment has been minimized.

Copy link
Member Author

commented Apr 5, 2019

Seems to be gone in current releases.

@dgoetz dgoetz closed this Apr 5, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.