Skip to content
An Eclipse Plug-in for YANG
Xtend TypeScript JavaScript HTML
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
diagram
yang-eclipse
.gitignore
.travis.yml
Jenkinsfile
LICENSE
README.md

README.md

yang-eclipse

An Eclipse Plug-in for YANG using a YANG language server and a YANG diagram based on sprotty.

Install it

YANG for Eclipse is available from the Eclipse Marketplace. Just drag this button to your running Eclipse

Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client

Build It Yourself

Requirements: Java 8, node 8, yarn 1.0.2

git clone https://github.com/theia-ide/yang-eclipse.git
cd yang-eclipse/diagram
yarn 
cd ../yang-eclipse
mvn clean install
You can’t perform that action at this time.